Search found 1817 matches

by Mangus
Thu Jan 17, 2019 8:57 am
Forum: General Motors
Topic: DOWNLOADING BIN FILES
Replies: 7
Views: 164

Re: DOWNLOADING BIN FILES

A bin file is a bin file. A bin definition is an XDF, and an acquisition definition is either an ADS (older format) or ADX (newer format).
by Mangus
Wed Jan 16, 2019 12:52 pm
Forum: General Motors
Topic: DOWNLOADING BIN FILES
Replies: 7
Views: 164

Re: DOWNLOADING BIN FILES

what happens when you drag and drop the individual bin file? what error do you get? Does the title bar show that the bin opened? Then try the XDF. What error?
by Mangus
Wed Jan 16, 2019 9:28 am
Forum: General Motors
Topic: DOWNLOADING BIN FILES
Replies: 7
Views: 164

Re: DOWNLOADING BIN FILES

After downloading, make sure the file extension matches what you expect, and not (for instance) .html. If you downloaded an XDF, make sure the file extension is .xdf. If you downloaded an ADS, change it to ADS. Then drag and drop the file into TunerPro.
by Mangus
Thu Dec 13, 2018 5:28 pm
Forum: TunerPro Discussion
Topic: Cutting log files down
Replies: 1
Views: 390

Unfortunately, no, this isn't possible to do.
by Mangus
Thu Dec 13, 2018 5:27 pm
Forum: Feature Suggestions
Topic: Edit axis easily / preset default axis numbers
Replies: 3
Views: 720

All great suggestions, some of which won't be too hard. I'll try to keep these in mind for the next time I dig in for the next release.
by Mangus
Thu Dec 13, 2018 5:26 pm
Forum: Report A Bug
Topic: Datastream failures / Realterm shows perfect
Replies: 6
Views: 2348

Do you have more than one PC to try this on? Many of the things you describe sound like some synchronization issues (bugs, as you say), but perhaps based around the rendering and/or memory performance of the host PC. I'm not sure I'll be able to untangle this issue for you in the near term. You migh...
by Mangus
Sun Nov 04, 2018 8:27 am
Forum: General Tuning Discussion
Topic: How to make a .idx file for a new application
Replies: 3
Views: 1236

What's an idx file?
by Mangus
Thu Sep 06, 2018 3:02 pm
Forum: General Motors
Topic: Emulation Not Working with APU1 and 165 ECM.
Replies: 1
Views: 959

Are you sure the emulation header is properly socketed in the ZIF in the ECM? Also, it's a good idea to disable the checksum if you haven't already. Do this by changing the mask ID byte (stock is either 0x32 or 0x6E for the '165) to 0xAA.
by Mangus
Thu Sep 06, 2018 3:00 pm
Forum: General Motors
Topic: Win10 and TunerPro
Replies: 2
Views: 1323

Yes
by Mangus
Thu Sep 06, 2018 2:58 pm
Forum: TunerPro Discussion
Topic: Emulation Flow - Ostrich and TunerPro RT
Replies: 2
Views: 947

Loosely, something like this: 0. Attach Ostrich to ECM/vehicle 1. Attach Ostrich to PC 2. Start TunerPro RT 3. Load BIN file 4. Load XDF file 5. Click the blue up arrow in the toolbar to upload the bin to the Ostrich 6. verify bin via toolbar button. Now you can key on the vehicle 7. To make increme...
by Mangus
Thu Sep 06, 2018 2:52 pm
Forum: Report A Bug
Topic: microsoft visual c++ 20** redistributable packages
Replies: 1
Views: 844

Thanks for the report. TunerPro itself shouldn't rely on anything but the VS2017 runtime, but I'll verify and fix any references to older libraries.

You should also be sure that third-party plug-ins aren't the culprit, as they may require older runtimes.
by Mangus
Thu Sep 06, 2018 2:50 pm
Forum: Report A Bug
Topic: Base Offset (XDF Header) limited to 0x7FFFFFFF
Replies: 1
Views: 717

Thanks for the report. I made some changes here several versions ago, and must have broken it. Will investigate.
by Mangus
Thu Sep 06, 2018 2:49 pm
Forum: Report A Bug
Topic: Check for update error
Replies: 3
Views: 1099

This is fixed in the latest version, which you'll have to download from the link Matrix mentioned. Once you're on that version, you should see the version check succeed again.

Sorry for the confusion.
by Mangus
Fri Jun 08, 2018 11:44 am
Forum: Report A Bug
Topic: Immediate crash when loading XDF
Replies: 23
Views: 9179

I've removed these DLLs from the installer for future versions, so this should no longer be an issue with the next release.

Thanks.
by Mangus
Wed May 23, 2018 8:15 am
Forum: Report A Bug
Topic: Problem getting tuner pro to work with win7 laptop
Replies: 5
Views: 1656

You won't run into other errors if you leave it as is. In general, what runs in Win7 runs fine in Win10.

Try deleting all of the DLL files in my documents/TunerPro files/ plug-ins.
by Mangus
Mon May 21, 2018 12:14 pm
Forum: Report A Bug
Topic: Problem getting tuner pro to work with win7 laptop
Replies: 5
Views: 1656

Sounds like some plug-in component you're using requires the VS2013 runtime, but it's not installed on one of your machines. The latest builds of TunerPro and TunerPro RT were built with VS2017, so it wouldn't be a core component causing this (hence your ability to run after you click through the er...
by Mangus
Mon Apr 02, 2018 2:12 pm
Forum: Report A Bug
Topic: scanning live data
Replies: 5
Views: 2688

The blank listview is another known issue, probably with the same underlying cause (bugs in the Microsoft C runtime).

I'll be rolling another build soon in hopes to address this, and I'll post it here for y'all to try ahead of general availability.
by Mangus
Tue Mar 20, 2018 5:47 am
Forum: Report A Bug
Topic: Immediate crash when loading XDF
Replies: 23
Views: 9179

Thanks for trying. I don't know how to tackle this at the moment. Hopefully I can find a local machine that reproduces this.
by Mangus
Sat Mar 17, 2018 2:51 pm
Forum: Report A Bug
Topic: Immediate crash when loading XDF
Replies: 23
Views: 9179

Please help me out by installing this: https://aka.ms/vs/15/release/VC_redist.x86.exe

Then run windows update, take any missing updates, reboot, and try to repro.
by Mangus
Fri Mar 16, 2018 2:19 pm
Forum: Report A Bug
Topic: Immediate crash when loading XDF
Replies: 23
Views: 9179

None of my machines repro it with files sent from other reporting parties. I suspect it has to do with different versions of the CRT being installed on different machines. I'm still trying to figure out how to fix this.
by Mangus
Tue Mar 06, 2018 8:57 am
Forum: TunerPro Discussion
Topic: sensor data not functioning during datalog/playback
Replies: 1
Views: 1453

What does "not functioning" mean? Are you not seeing any data/text at all in the data lists? Could it be the issue described here?
http://forum.tunerpro.net/viewtopic.php?t=4529
by Mangus
Mon Feb 26, 2018 11:43 am
Forum: Feature Suggestions
Topic: Why not pictures for bits?
Replies: 6
Views: 6494

Why not define a scalar for exactly this purpose?
by Mangus
Wed Feb 14, 2018 1:58 pm
Forum: General Motors
Topic: XDF and ADS/ADX files for a 1988 305/350 TPI.
Replies: 1
Views: 1778

''88 uses the $32B defintiions. For data logging, you can use the 1227165_6E.ads/ADX. You can also upload and use a $6E tune and use the full 6E definitions, but you'll need to unplug the cold start injector when doing so.
by Mangus
Thu Jan 25, 2018 1:52 pm
Forum: TunerPro Discussion
Topic: XDF Import from Delimited File
Replies: 3
Views: 2008

Sorry about that. The feature is only partially implemented, with no documentation (obviously). I mean to get back to work on it, and to post some minimal documentation. One day soon.
by Mangus
Thu Jan 25, 2018 1:51 pm
Forum: Feature Suggestions
Topic: I love TP: But 16bit (LoHi) and Undo function is urgently
Replies: 2
Views: 1767

Thanks Dex.

Undo is also there, but on a per-editor basis. If you close the editor (e.g. a table editor), then the undo history is reset.
by Mangus
Sun Jan 14, 2018 6:57 pm
Forum: Report A Bug
Topic: scanning live data
Replies: 5
Views: 2688

Thanks for pinging me about this. I can't reproduce it on the machine I'm now, but will try a few others.
by Mangus
Sat Dec 02, 2017 1:57 pm
Forum: Report A Bug
Topic: Can't get it to start... the application that is
Replies: 5
Views: 4304

The latest version now requires the Visual Studio 2017 redist. The TunerPro installer should automatically install it, but some folks still seem to be seeing issues. You can manually download and install it from here: https://go.microsoft.com/fwlink/?LinkId=746572 Then run Windows Update, reboot, an...
by Mangus
Sat Dec 02, 2017 1:55 pm
Forum: Report A Bug
Topic: Cannot open settings file
Replies: 1
Views: 1749

The settings files are written to your documents\tunerpro files\ folder. Perhaps something on your computer is preventing TunerPro from accessing that.

You shouldn't need to, but try running TunerPro as an administratore (right-click on the shortcut, select "run as administrator").
by Mangus
Tue Oct 31, 2017 8:48 am
Forum: General Motors
Topic: Newbie Question - Correct cable for 1992 Corvette
Replies: 3
Views: 2805

Pretty much any USB based OBDI GM ALDL cable should work. Moates.net makes the ALDU1 for this purpose. There are others out there as well.
by Mangus
Tue Oct 31, 2017 8:47 am
Forum: General Motors
Topic: ECM 1228253/1619264
Replies: 2
Views: 2435

Actually looking at the ECM should yield the part number for the ECM. Looking at the chip or memcal should yield the BCC code. Those two things combined, along with what engine is in it, should give you the info you need to determine the definitions to use.
by Mangus
Tue Oct 31, 2017 8:45 am
Forum: Report A Bug
Topic: Checksum license location?
Replies: 1
Views: 2052

You'd have to reach out to whomever wrote the checksum plug-in. They would have implemented their licensing logic on their own.
by Mangus
Mon Sep 25, 2017 4:01 pm
Forum: TunerPro Discussion
Topic: DA: Not Connected?
Replies: 4
Views: 3368

No, it doesn't require a license. You'll need to set the interface type to "AutoProm/MAFTPro" on the data acquisition tab of preferences. Then you'll need to load the definition (ADS or ADX file) provided by the MAFTPro folks to enable logging.

-Mark
by Mangus
Mon Sep 25, 2017 12:00 pm
Forum: Report A Bug
Topic: Immediate crash when loading XDF
Replies: 23
Views: 9179

I've made no changes to XDFs in between. The major change was moving to a new compiler, and ultimately a new C runtime.

Maybe try running windows update to make sure your PC has the llatest runtime installed?

I'm grasping at straws; I have no explanation for why it would work on mine and not yours.
by Mangus
Mon Sep 25, 2017 11:14 am
Forum: Report A Bug
Topic: Immediate crash when loading XDF
Replies: 23
Views: 9179

Is there any way to generate a log file of the crash? Not unless you have Visual Studio installed, and can attach and generate a crash dump. Are your settings the same between the two machines (win7/win10)? I can load both XDFs, here. What happens if you load it on the Win7 machine, save it out in ...
by Mangus
Mon Sep 25, 2017 9:22 am
Forum: Report A Bug
Topic: Immediate crash when loading XDF
Replies: 23
Views: 9179

Can you please email me a bin? Does it crash if you don't have a bin loaded?

Aside from that, you're using exactly the same setup I am, and I cannot repro.
by Mangus
Mon Sep 25, 2017 8:10 am
Forum: TunerPro Discussion
Topic: DA: Not Connected?
Replies: 4
Views: 3368

We'll need more info to be helpful.

What vehicle? What definitions?

What do you see when you test for valid cable? Do you have your COM port set to match the one your cable uses in preferences?
by Mangus
Mon Sep 25, 2017 8:03 am
Forum: Report A Bug
Topic: Immediate crash when loading XDF
Replies: 23
Views: 9179

Are you using the latest build? I can load it without issue. What language/locale is your PC set to?
by Mangus
Tue Aug 29, 2017 7:15 am
Forum: Ford
Topic: MINPW Zeros Out
Replies: 2
Views: 2756

This is an intentional feature in the XDF, according to its author.
by Mangus
Thu Aug 10, 2017 11:48 am
Forum: Report A Bug
Topic: Crashing when entering or editing custom
Replies: 14
Views: 9499

The issue described here has nothing to do with loading XDFs. If you see a crash loading an XDF, best to email me the files I need and instructions to reproduce the issue. Regarding the original issue (crashing when entering the custom tools configuration), I haven't been able to reproduce this, but...
by Mangus
Tue Aug 08, 2017 10:48 am
Forum: General Motors
Topic: aldu1/cabl1 affects tune
Replies: 3
Views: 3325

If you have a 1227165 ECM, I recommend using a 6E tune, then use 8192 baud. Unplug the cold start injector, since it isn't used in the 6E mask.

With that, you only need the 10k while connecting to t he 8192 baud stream. Once you start getting data, you can remove the 10k.
by Mangus
Fri Aug 04, 2017 9:01 am
Forum: General Motors
Topic: aldu1/cabl1 affects tune
Replies: 3
Views: 3325

After you connect, you can disconnect the 10K. That'll help the running issue when the cable is connected. Also, for some masks, there is a spark adder in ALDL mode. In $6E, I zero this value out. I'm not sure if this exists in the $32 mask. It'll have to be a point of research for the reader. =) MA...
by Mangus
Fri Aug 04, 2017 8:59 am
Forum: Report A Bug
Topic: Can't get it to start... the application that is
Replies: 5
Views: 4304

Correct. Install this one, specifically:

https://www.microsoft.com/en-us/downloa ... x?id=52685

You may also need to check for Windows updates after you install the above.

I'll fix this issue in the next release.
by Mangus
Mon Jul 24, 2017 10:30 am
Forum: TunerPro Discussion
Topic: Newbie
Replies: 1
Views: 2304

Dragging and dropping an ADS into the main window will automatically import it to ADX. You can then save the file yourself, or wait for TunerPro to prompt you to do so when you attempt to close the session. FWIW, on your '87, if it's running $32B, you can actually use the 1227165_6E.adx to get data ...
by Mangus
Thu Jul 20, 2017 1:54 pm
Forum: TunerPro Discussion
Topic: getting started ...not
Replies: 3
Views: 3459

You'd think.
by Mangus
Fri Jul 14, 2017 11:27 am
Forum: General Motors
Topic: Reading 1994 Buick Century "Service Engine Soon" c
Replies: 11
Views: 6139

try A & K. Sounds like your K pin should actually be B.
by Mangus
Tue Jun 20, 2017 11:33 am
Forum: TunerPro Discussion
Topic: getting started ...not
Replies: 3
Views: 3459

Ini a generic sense, this is a great place to start: https://www.youtube.com/results?search_query=APU1 https://www.youtube.com/results?search_query=tunerpro More specifically, in order for the community to assist you, it will be helpful for you to include the year, make, model, and engine of your ve...
by Mangus
Tue Jun 13, 2017 10:53 am
Forum: Report A Bug
Topic: Alarm message upon first use
Replies: 2
Views: 3314

The redist should solve the problem, and it's run automatically when installing TunerPro. Perhaps the redist installation isn't successfully completing? When you install the redist by itself, does it fully complete successfully?

https://www.microsoft.com/en-us/downloa ... x?id=52685
by Mangus
Tue May 30, 2017 12:18 pm
Forum: General Motors
Topic: TUNER PRO CD
Replies: 1
Views: 2738

Sounds like you did. There are two retailers through which you can register TunerPro. Myself (TunerPro.net) and Moates.net.

-M
by Mangus
Fri Apr 21, 2017 12:32 pm
Forum: Feature Suggestions
Topic: Yocto Knob!
Replies: 1
Views: 2610

Yes, cool idea. This is something I thought about when the APU1 came out, using the additional 3 channels of A/D for the same purpose. For your suggestion here, though, it would have to be behind another feature that's near the top of my current list, which is to enable the ability to log from multi...
by Mangus
Tue Mar 28, 2017 2:24 pm
Forum: TunerPro Discussion
Topic: Bin Restructuring with PLUG-IN
Replies: 1
Views: 2660

Bin editing is not exposed to the plug-ins via any TunerPro interfaces. The emulation plug-in interface does expose read access to the memory being passed through to the emulator, though it won't serve the purpose you outline below. You could always crack the bin yourself (CreateFile/ReadFile/WriteF...