Search found 1824 matches

by Mangus
Sun Dec 14, 2014 11:44 am
Forum: General Motors
Topic: Need Step by Step Help for 91 Corvette
Replies: 20
Views: 22635

I've uploaded a definition for you to try. http://www.tunerpro.net/downloadbindefs.htm

It's on the 8D line under GM.
by Mangus
Sat Dec 13, 2014 9:26 am
Forum: General Motors
Topic: Need Step by Step Help for 91 Corvette
Replies: 20
Views: 22635

That Thirdgen thread is a good one. I'm glad to see you chipping away at this on your own. If the data is no longer erratic, then you're probably fine. You should be getting ~8hz when connected. You can right-click on dashboard gauges to select whatever you want to display in each gauge. I'll take a...
by Mangus
Fri Dec 12, 2014 4:07 pm
Forum: General Motors
Topic: Need Step by Step Help for 91 Corvette
Replies: 20
Views: 22635

OK. See my edit above.
by Mangus
Fri Dec 12, 2014 4:00 pm
Forum: General Motors
Topic: Need Step by Step Help for 91 Corvette
Replies: 20
Views: 22635

You don't need the 10k. Does your Vette have a digital dashboard? There's a gentlemen that has a working definition here: http://www.corvetteforum.com/forums/c4-scan-and-tune/3274140-how-to-silence-ccm-and-dash-1990-corvette.html I've requested that he send it to me, and I"ll put it up on the websit...
by Mangus
Fri Dec 12, 2014 3:27 pm
Forum: General Motors
Topic: Need Step by Step Help for 91 Corvette
Replies: 20
Views: 22635

1. Download the $8D ADS file. 2. Open TunerPro RT and plug your USB cable into your computer 3. Drag and drop the $8D ADS file into the main TunerPro window to import it into the newer ADX format. 4. When it prompts you to save the new 8D.ADX file, save it to the location of your choice 5. Open up T...
by Mangus
Mon Dec 08, 2014 5:46 pm
Forum: General Motors
Topic: 95 LT1 Corvette Erratic Data Logging
Replies: 6
Views: 7522

The cable is probably fine if you're getting any data at all, even erratic or nonsensical data. The 94/95 LT1 masks are chatty on the ALDL line with the dashboard, BCM, TCM, etc, so usually there's some listening and silencing done in the communication command set. I've not seen a definition that fu...
by Mangus
Mon Dec 08, 2014 9:46 am
Forum: General Motors
Topic: Who Needs An ADS or ADX?
Replies: 367
Views: 488483

The ALDL line on this vehicle has a body control module on it, and the command/response flow is a bit different form other vehicles. The first thing the definition needs to do is listen for the F0 poll command. Details: MESSAGE CODE $F0 IS USED BY THE ECM TO POLL FOR THE PRESENCE OF AN ALDL TESTING ...
by Mangus
Mon Dec 08, 2014 9:02 am
Forum: General Motors
Topic: 95 LT1 Corvette Erratic Data Logging
Replies: 6
Views: 7522

I've personally seen it work fine with 94-95 F and Y bodies. It's all in the definition. I have not created a single 94-95 definition myself. In fact, I haven't created a single definition for any vehicle outside of the $6E definitions for the single test vehicle that I actually own and have access ...
by Mangus
Mon Dec 08, 2014 9:00 am
Forum: General Motors
Topic: tunerpro elm327 cant get to work for obdII
Replies: 1
Views: 3698

You can do very basic scanning with the ELM327 plug-in available on the site. It includes a very basic definition. you need an ELM327-based cable for this.
by Mangus
Mon Nov 24, 2014 11:06 am
Forum: General Motors
Topic: 1986 Corvette
Replies: 9
Views: 9998

Correct.
by Mangus
Sun Nov 23, 2014 7:20 pm
Forum: General Motors
Topic: 1986 Corvette
Replies: 9
Views: 9998

The code for 8192 isn't included in the $32 bins. $32b and $6E have it. No reason not to update $32 and $32B to $6E. Just unplug the cold start injector when doing so.
by Mangus
Fri Nov 21, 2014 12:06 pm
Forum: Feature Suggestions
Topic: Selecting more then one table/scalar for copying?
Replies: 2
Views: 5771

Not possible. However, if they're all very similar, create one scalar exactly as you want it, then copy it (Ctrl + C) and paste it (Ctrl + V) to make a copy. Then do a quick edit of the copy.
by Mangus
Fri Nov 21, 2014 12:04 pm
Forum: Feature Suggestions
Topic: More instances as just one?
Replies: 1
Views: 4392

See the tools menu. Or add the "-multiinstance" to your shortcut path.
by Mangus
Mon Nov 17, 2014 1:56 pm
Forum: General Motors
Topic: Need TunerPro RT Version 4.14 help
Replies: 1
Views: 3202

Describe how you have your ALDL preferences set up. The Interface type should be set to "AutoProm" if the AutoProm is being detected by TunerPro at startup.
by Mangus
Thu Nov 06, 2014 12:55 pm
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

There's a fix coming in the next build that should solve the recursion issue that is probably what's keeping this from working for you. Meanwhile, use "THIS()" instead of "X" in your equation, and it should work. Note that you can use a global table equation of CELL(ROW()+1;0;FALSE)-THIS()*FACTOR+OF...
by Mangus
Wed Oct 29, 2014 2:33 pm
Forum: Feature Suggestions
Topic: Collection of UI improvements
Replies: 4
Views: 7792

Thanks for the feedback. It's truly appreciated when people take the time to offer feedback like this. For suggestion #4, you could accomplish something similar by adding a category (call it "Frequently Used") and assign the items that you frequently use to it. Make it the first category in the list...
by Mangus
Wed Oct 29, 2014 8:25 am
Forum: Report A Bug
Topic: TunerProRT Hangs Initializing Quaterhorse
Replies: 3
Views: 5786

I don't know how this is possible. TunerPro versions are completely self contained. I'll try again to reproduce the issue.
by Mangus
Wed Oct 22, 2014 9:59 am
Forum: General Motors
Topic: Red Devil wireless ALDL adapter doesn't work - help
Replies: 7
Views: 10512

You want the $1D files, second to the last entry in the GM table here: http://www.tunerpro.net/downloadBinDefs.htm
by Mangus
Wed Oct 22, 2014 8:55 am
Forum: General Motors
Topic: Red Devil wireless ALDL adapter doesn't work - help
Replies: 7
Views: 10512

I don't have any experience with Red Devil cables myself, but any standard ALDL cable that connects either through serial or a USB port (using an FTDI or similar usb->serial conversion chip) should work just fine. Someone mentioned something about a Bluetooth ALDL cable. I haven't tried that myself,...
by Mangus
Tue Oct 21, 2014 1:49 pm
Forum: General Motors
Topic: Red Devil wireless ALDL adapter doesn't work - help
Replies: 7
Views: 10512

First question: how are you running TunerPro on Android?
by Mangus
Tue Oct 21, 2014 1:48 pm
Forum: Report A Bug
Topic: TunerProRT Hangs Initializing Quaterhorse
Replies: 3
Views: 5786

So rolling back and then forward again resolves the issue in 8414?
by Mangus
Wed Oct 15, 2014 5:16 pm
Forum: General Motors
Topic: NOT EMULATING , HARDWARE NOT FOUNDDA NOT CONNECTED
Replies: 20
Views: 24602

Great, then your cable and COM port selections are correct. Now it's just a matter of ensuring you're using the right definition for your vehicle. Load the definition, plug the cable in, turn on the ignition, and hit the connect button in the toolbar (or menu option). If it doesn't connect the first...
by Mangus
Wed Oct 15, 2014 3:50 pm
Forum: General Motors
Topic: NOT EMULATING , HARDWARE NOT FOUNDDA NOT CONNECTED
Replies: 20
Views: 24602

Suggestions:

1) Stop with the all caps (please)
2) Make sure you do the cable test with the ignition off, or with the ALDL connector disconnected from the vehicle
by Mangus
Wed Oct 08, 2014 2:37 pm
Forum: General Motors
Topic: NOT EMULATING , HARDWARE NOT FOUNDDA NOT CONNECTED
Replies: 20
Views: 24602

Yes. In your case, Walter, use the ADX that's included in the ELM327 plug-in package (And I believe it's also pat of the TunerPro RT installation package. In the other gentleman's case, he needs to download the proper ADS or ADX from the website, and load it into TunerPro (drag and drop it into the ...
by Mangus
Wed Oct 08, 2014 1:00 pm
Forum: General Motors
Topic: NOT EMULATING , HARDWARE NOT FOUNDDA NOT CONNECTED
Replies: 20
Views: 24602

You haven't mentioned what ADS/ADX you're using to connect to the car with.
by Mangus
Tue Oct 07, 2014 6:25 pm
Forum: Report A Bug
Topic: Broke My Definition File?
Replies: 4
Views: 7167

I neglected to update this thread - this issue is fixed in the latest build. The fix is temporary, and comes at the cost of the amount of time it takes to load an XDF (noticeable only with large XDFs). I'll implement a more robust fix soon, which should actually improve performance beyond that of th...
by Mangus
Fri Oct 03, 2014 7:45 pm
Forum: Feature Suggestions
Topic: Save Active Editor Automatic
Replies: 5
Views: 7471

It is indeed possible.
by Mangus
Fri Oct 03, 2014 10:04 am
Forum: Feature Suggestions
Topic: Save Active Editor Automatic
Replies: 5
Views: 7471

No, not currently.
by Mangus
Tue Sep 23, 2014 2:13 pm
Forum: Feature Suggestions
Topic: changing in wireframe
Replies: 2
Views: 5235

Doesn't matter what view you're in, if you have a cell selected (even if selected via the graph), you can increment/decrement using the numpad +/- or Ctrl +/Ctrl -.

You can assign the keys to whatever you want in preferences.
by Mangus
Tue Sep 23, 2014 9:20 am
Forum: Report A Bug
Topic: small bug in graphic view
Replies: 5
Views: 7858

Fixed for the next build.
by Mangus
Tue Sep 23, 2014 8:53 am
Forum: Report A Bug
Topic: small bug in graphic view
Replies: 5
Views: 7858

I appreciate specialists like you.

OK, so now I see that, if the graph is already open in wireframe and you add another compare bin, the new compare bin isn't added to the graph at all. Is that what you're seeing, too?
by Mangus
Tue Sep 23, 2014 8:13 am
Forum: Report A Bug
Topic: small bug in graphic view
Replies: 5
Views: 7858

I can't reproduce this issue. With a compare bin loaded, I can switch to wireframe, select points, deselect points, move back to filled mode, and still select and deselect points.
by Mangus
Mon Sep 22, 2014 6:25 am
Forum: Feature Suggestions
Topic: show the value of a cell continuously
Replies: 8
Views: 9619

Correct - you'd have to modify the ECU code to send RAM data out on the datalogging or OBD line.
by Mangus
Sun Sep 21, 2014 4:10 pm
Forum: Feature Suggestions
Topic: show the value of a cell continuously
Replies: 8
Views: 9619

To clarify further, the Ostrich replaces the ROM. it does not itself have access to RAM.
by Mangus
Sat Sep 20, 2014 6:59 am
Forum: Feature Suggestions
Topic: show the value of a cell continuously
Replies: 8
Views: 9619

Ah. That's the way the quarterhprse works. The Ostrich can only access its own memory, and not the ECU's RAM.
by Mangus
Fri Sep 19, 2014 2:36 pm
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

I'll consider this resolved.
by Mangus
Thu Sep 18, 2014 8:20 am
Forum: Feature Suggestions
Topic: show the value of a cell continuously
Replies: 8
Views: 9619

Hi Bernhard,

I don't understand. :(

When emulating with the Ostrich, the value in a cell will only change if you change it yourself. No cells should change automatically.

-M
by Mangus
Wed Sep 17, 2014 2:22 pm
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

Did you get it working?
by Mangus
Wed Sep 17, 2014 2:22 pm
Forum: TunerPro Discussion
Topic: key
Replies: 4
Views: 5421

Sounds like quite an opportunity cost to me. =)
by Mangus
Tue Sep 16, 2014 4:30 pm
Forum: Report A Bug
Topic: Plugin problem
Replies: 5
Views: 7599

Yes, that's implemented in the plug-in itself. My guess is that it auto-detects the port.
by Mangus
Tue Sep 16, 2014 1:51 pm
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

Create a new table that represents the row axis. Address 0x29806. Set up the conversion how you need it. Then in the KFDZWOB table row tab, select "Linked, Scale" and specify the new table you created. If you set the global equation for the new row axis table to be something like: CELL(ROW()+1;0;FAL...
by Mangus
Tue Sep 16, 2014 1:04 pm
Forum: Report A Bug
Topic: Plugin problem
Replies: 5
Views: 7599

The plug-in downloaded directly from that link appears to load correctly on my machine using a bone-stock TunerPro RT installation. It appears to require the MSVCR100.dll that you already have in the plug-in directory, so you should be good, there. I'm not sure what would cause this that's unique to...
by Mangus
Tue Sep 16, 2014 9:42 am
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

We're speaking specifically about the row axis conversion. Not the column, not the main table. My suggestion is based on the information you provided in the initial posts.

What does the "EPROM, subtract" option do in WinOLS? I don't have any experience with WinOLS.
by Mangus
Tue Sep 16, 2014 9:15 am
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

the length of it is attributed to the fact that i'm using 4 IF()'s and modifying the equation based on the cell index number. it shouldn't be any more work for the application than specifying an equation for each cell in the axis, just instead of the application conditionally applying an equation b...
by Mangus
Tue Sep 16, 2014 8:55 am
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

If you need more than 255 characters, there's almost certainly an easier way. That's a beefcake of an equation you've got there, and it would be (at best) horribly slow and inefficient to calculate across the table.
by Mangus
Tue Sep 16, 2014 7:56 am
Forum: TunerPro Discussion
Topic: key
Replies: 4
Views: 5421

Use it on as many computers as you personally own, remembering that it has your personal information embedded in it.

Thanks!
by Mangus
Tue Sep 16, 2014 7:54 am
Forum: Report A Bug
Topic: Plugin problem
Replies: 5
Views: 7599

My guess is that you don't have the C++ runtime DLLs necessary to run it. Can you link me to the plug-in that you downloaded? I'll look.
by Mangus
Tue Sep 16, 2014 7:50 am
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

Even with the per-cell equation on the last cell?
by Mangus
Tue Sep 16, 2014 12:01 am
Forum: TunerPro Discussion
Topic: something wrong with my axis conversion?
Replies: 20
Views: 21604

I'll have to add error messaging. The equations fail to be saved because they're invalid. The first one fails because you should be using semicolons for parameter delimiters, not commas. I'll be taking a closer look at the second one. Another (perhaps easier and more efficient) way to do the second ...
by Mangus
Mon Sep 15, 2014 12:25 pm
Forum: TunerPro Discussion
Topic: created definition how do i setup dash and live trace?
Replies: 1
Views: 3434

There are stickies atop this very forum that cover both of those topics.