Fuel Map Data Looping

Report bugs found in TunerPro. Please be sure to include as much info as possible, including system specs, OS, repro steps and TunerPro version number.

Moderators: Mangus, robertisaar, dex

Post Reply
pablo
Posts: 30
Joined: Sun Oct 09, 2011 5:24 am

Fuel Map Data Looping

Post by pablo » Sun Oct 23, 2011 3:00 pm

HI,

I was trying to decrease my Fuel ratio in the fuel table at around 2000rpms/13 TP. When i got down to the Value 132ish the fuel seemed to loop back on it's self. The ratio on my Zeitronix AFR was getting close to where it should be (13-14+ AFR), then when i got to the value 132ish its seemed to loop back around on itself and went high again and started over fueling again??? (10.9 AFR) while i was trying to dial it in.

A bit like the loop back around on the fuel table, when u hit the last column it can go back to the first column in the fuel table this still does happen occasionally with the latest patch i saw it happen again recently, either that or just random erroneous data under WOT caused it?

Anyone else had this happen or know a solution?

Would editing the parameters in the XDF to a wider scale solve this? my current range in my XDF in my Fuel table is Low -100 to 255 High range. Not used Tunerpro much, just learning, but have quite a few teething problems ;(

Any help or solutions would be greatly appreciated please, thanks.

JP86SS
Posts: 217
Joined: Thu Apr 22, 2004 5:49 pm
Location: Strongsville, Ohio
Contact:

Post by JP86SS » Wed Oct 26, 2011 2:14 pm

Sounds like the negative value is getting you. The variable you are changing may not be signed and take positive values only.
Entering a negative can give the effect of a high positive value in some cases.
Confirm the scaling and conversion numbers you have there.
Image

pablo
Posts: 30
Joined: Sun Oct 09, 2011 5:24 am

Post by pablo » Thu Oct 27, 2011 7:25 am

Hi

The range i have set for my fuel table its -100 low - 255 high and the output types, integer data size 8bit, equation X. The original cell value was 193 to start with.

The original Low range was set to Zero "0" and high 200.

The cells are in the closed Loop section of the map "Red section??" Nissan ca18det BIN/XDF. Maybe it's, a gremlin at work, the car runs funny now when i hit the effected cells and i cant get my AFR right ;(

Something else could be causing a problem because the cells around them are no where near that low and fine. The cells have made a hole in the fuel map. Everything else in the surrounding area is much higher, lowest value being 176 and highest 212 and i can achieve the correct AFR??? But the fuel shouldn't loop back like that anyway correct?
As soon as i hit this problem i stopped remapping the fuel table in case other values would need to go that low and lower and cause a problem.

Having a range that goes into negative numbers represented by a integer maybe the problem? aren't all integers positive whole numbers??

Thank yon very much for mulling this one over.

Post Reply