Version 5.00.8383 not running on specific notebook

Report bugs found in TunerPro. Please be sure to include as much info as possible, including system specs, OS, repro steps and TunerPro version number.

Moderators: Mangus, robertisaar, dex

Post Reply
VassilisA
Posts: 3
Joined: Sun May 11, 2014 6:07 am

Version 5.00.8383 not running on specific notebook

Post by VassilisA » Sun May 11, 2014 6:35 am

Hello, I've installed the latest 8383 version (after uninstalling v.7427 which run fine) and cannot get it running on the laptop I use for tuning purposes (Toshiba, Intel Pentium3@900Mhz, 256MB of RAM, Windows XP SP3).

Please let me notice that it runs fine on another laptop I have, so I know it has to do with the specific machine.

Firstly I had a 'GetLogicalProcessorInformation', KERNEL32.dll error, so I thought it was the XP SP3 which was missing, I installed it and now it does not produce that error anymore but the "TunerPro... has encountered a problem and needs to close....'

Below you can find the '..appcompat.txt' file containing info about this problem.
Sorry for copying-pasting its content but I don't seem to be able to attach it here.

Any thoughts would be highly appreciated!
Many thanks and keep up the good work..

'<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="TunerPro.exe" FILTER="GRABMI_FILTER_PRIVACY">
<MATCHING_FILE NAME="ADXEditor.dll" SIZE="465408" CHECKSUM="0xBEAC04A9" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/01/2014 02:55:12" UPTO_LINK_DATE="05/01/2014 02:55:12" />
<MATCHING_FILE NAME="MoatesOnboardLogger.dll" SIZE="361984" CHECKSUM="0x7CE8BCFD" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/01/2014 02:55:02" UPTO_LINK_DATE="05/01/2014 02:55:02" />
<MATCHING_FILE NAME="msvcp100.dll" SIZE="421200" CHECKSUM="0x2A20605" BIN_FILE_VERSION="10.0.30319.1" BIN_PRODUCT_VERSION="10.0.30319.1" PRODUCT_VERSION="10.00.30319.1" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2010" FILE_VERSION="10.00.30319.1" ORIGINAL_FILENAME="msvcp100.dll" INTERNAL_NAME="msvcp100.dll" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x6CEB5" LINKER_VERSION="0xA0000" UPTO_BIN_FILE_VERSION="10.0.30319.1" UPTO_BIN_PRODUCT_VERSION="10.0.30319.1" LINK_DATE="03/18/2010 07:53:01" UPTO_LINK_DATE="03/18/2010 07:53:01" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="msvcp120.dll" SIZE="455328" CHECKSUM="0x37EF115E" BIN_FILE_VERSION="12.0.21005.1" BIN_PRODUCT_VERSION="12.0.21005.1" PRODUCT_VERSION="12.00.21005.1" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2013" FILE_VERSION="12.00.21005.1 built by: REL" ORIGINAL_FILENAME="msvcp120.dll" INTERNAL_NAME="msvcp120.dll" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x778ED" LINKER_VERSION="0xA0000" UPTO_BIN_FILE_VERSION="12.0.21005.1" UPTO_BIN_PRODUCT_VERSION="12.0.21005.1" LINK_DATE="10/05/2013 02:43:57" UPTO_LINK_DATE="10/05/2013 02:43:57" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="msvcr100.dll" SIZE="770384" CHECKSUM="0x6C2B1057" BIN_FILE_VERSION="10.0.30319.1" BIN_PRODUCT_VERSION="10.0.30319.1" PRODUCT_VERSION="10.00.30319.1" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2010" FILE_VERSION="10.00.30319.1" ORIGINAL_FILENAME="msvcr100_clr0400.dll" INTERNAL_NAME="msvcr100_clr0400.dll" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xC53CC" LINKER_VERSION="0xA0000" UPTO_BIN_FILE_VERSION="10.0.30319.1" UPTO_BIN_PRODUCT_VERSION="10.0.30319.1" LINK_DATE="03/18/2010 07:52:30" UPTO_LINK_DATE="03/18/2010 07:52:30" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="msvcr120.dll" SIZE="970912" CHECKSUM="0xC7FFB849" BIN_FILE_VERSION="12.0.21005.1" BIN_PRODUCT_VERSION="12.0.21005.1" PRODUCT_VERSION="12.00.21005.1" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2013" FILE_VERSION="12.00.21005.1 built by: REL" ORIGINAL_FILENAME="msvcr120.dll" INTERNAL_NAME="msvcr120.dll" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xFB320" LINKER_VERSION="0xA0000" UPTO_BIN_FILE_VERSION="12.0.21005.1" UPTO_BIN_PRODUCT_VERSION="12.0.21005.1" LINK_DATE="10/05/2013 02:43:50" UPTO_LINK_DATE="10/05/2013 02:43:50" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="PromIO.dll" SIZE="292352" CHECKSUM="0xA6F7A133" BIN_FILE_VERSION="1.0.3849.1" BIN_PRODUCT_VERSION="1.0.0.1" PRODUCT_VERSION="1, 0, 0, 1" FILE_DESCRIPTION="Moatesware Prom IO Library" PRODUCT_NAME="Moatesware Prom IO Library" FILE_VERSION="1, 0, 3849, 1" ORIGINAL_FILENAME="PromIO.dll" INTERNAL_NAME="Moates Prom IO" LEGAL_COPYRIGHT="Copyright (C) RusnaMark SW" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.0.3849.1" UPTO_BIN_PRODUCT_VERSION="1.0.0.1" LINK_DATE="05/01/2014 02:54:46" UPTO_LINK_DATE="05/01/2014 02:54:46" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="ScannerProModule.dll" SIZE="426496" CHECKSUM="0x46630C9C" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/01/2014 02:55:07" UPTO_LINK_DATE="05/01/2014 02:55:07" />
<MATCHING_FILE NAME="TPChecksumPlugin.dll" SIZE="16384" CHECKSUM="0xE2E006E6" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/01/2014 02:54:36" UPTO_LINK_DATE="05/01/2014 02:54:36" />
<MATCHING_FILE NAME="TPMoatesEmulatorPlugin.dll" SIZE="60416" CHECKSUM="0xB6C343A6" BIN_FILE_VERSION="1.0.0.1" BIN_PRODUCT_VERSION="1.0.0.1" PRODUCT_VERSION="1, 0, 0, 1" FILE_DESCRIPTION="Moates &amp; XTronics Device Plugin for TunerPro" COMPANY_NAME="RusnaMark Software" PRODUCT_NAME="Moates &amp; XTronics Device Plugin for TunerPro" FILE_VERSION="1, 0, 0, 1" ORIGINAL_FILENAME="TPMoates.dll" INTERNAL_NAME="TPM.dll" LEGAL_COPYRIGHT="Copyright (C) RusnaMark Software" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.0.0.1" UPTO_BIN_PRODUCT_VERSION="1.0.0.1" LINK_DATE="05/01/2014 02:54:38" UPTO_LINK_DATE="05/01/2014 02:54:38" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="TunerPro.exe" SIZE="1093632" CHECKSUM="0x7299ED59" BIN_FILE_VERSION="5.0.8383.0" BIN_PRODUCT_VERSION="5.0.0.0" PRODUCT_VERSION="5, 0, 0, 0" FILE_DESCRIPTION="TunerPro - Automobile Tuning and Diagnostic Software" COMPANY_NAME="Creational Technologies, LLC" PRODUCT_NAME=" TunerPro Application" FILE_VERSION="5, 0, 8383, 0" ORIGINAL_FILENAME="TunerPro.exe" INTERNAL_NAME="TunerPro" LEGAL_COPYRIGHT="Copyright (C) Creational Technologies, LLC - All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="5.0.8383.0" UPTO_BIN_PRODUCT_VERSION="5.0.0.0" LINK_DATE="05/01/2014 02:55:52" UPTO_LINK_DATE="05/01/2014 02:55:52" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="unins000.exe" SIZE="715253" CHECKSUM="0x30FA562F" BIN_FILE_VERSION="51.52.0.0" BIN_PRODUCT_VERSION="0.0.0.0" FILE_DESCRIPTION="Setup/Uninstall" FILE_VERSION="51.52.0.0" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x60000" UPTO_BIN_FILE_VERSION="51.52.0.0" UPTO_BIN_PRODUCT_VERSION="0.0.0.0" LINK_DATE="06/19/1992 22:22:17" UPTO_LINK_DATE="06/19/1992 22:22:17" VER_LANGUAGE="Language Neutral [0x0]" />
<MATCHING_FILE NAME="XDFEditor.dll" SIZE="526336" CHECKSUM="0x1F518A98" BIN_FILE_VERSION="2.0.3801.1" BIN_PRODUCT_VERSION="1.0.0.1" PRODUCT_VERSION="1, 0, 0, 1" FILE_DESCRIPTION="XDF Definition File Editor" PRODUCT_NAME="XDF Definition File Editor" FILE_VERSION="2, 0, 3801, 1" ORIGINAL_FILENAME="XDFEditor.dll" INTERNAL_NAME="XDF Editor" LEGAL_COPYRIGHT="Copyright (C) RusnaMark SW" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="2.0.3801.1" UPTO_BIN_PRODUCT_VERSION="1.0.0.1" LINK_DATE="05/01/2014 02:55:12" UPTO_LINK_DATE="05/01/2014 02:55:12" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="kernel32.dll" SIZE="989696" CHECKSUM="0x7D737C09" BIN_FILE_VERSION="5.1.2600.5512" BIN_PRODUCT_VERSION="5.1.2600.5512" PRODUCT_VERSION="5.1.2600.5512" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.5512 (xpsp.080413-2111)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xF44A2" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.5512" UPTO_BIN_PRODUCT_VERSION="5.1.2600.5512" LINK_DATE="04/14/2008 00:11:24" UPTO_LINK_DATE="04/14/2008 00:11:24" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
</DATABASE>
'

User avatar
dex
The Ford Guy
Posts: 550
Joined: Thu Oct 07, 2004 6:38 am

Post by dex » Mon May 12, 2014 2:51 am

In the same boat here, I get a similar error message stating "The procedure entry point GetLogicalProcessorInformation could not be located in the dynamic link library KERNEL32.DLL."

Uninstalling and reinstalling the previously working version (8200) gets me back to a working version. Running XP professional with SP2. An oddity is that this new version (8383) works on on my laptop with the same version of Windows.

SD16
Posts: 26
Joined: Wed Oct 19, 2005 3:43 am
Location: Deutschland

Post by SD16 » Thu May 15, 2014 6:27 am

Have, unfortunately, the same problem!

User avatar
Mangus
TunerPro Author
Posts: 1827
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Thu May 15, 2014 6:46 am

Try installing this redist and let me know if it gets you working:
http://www.microsoft.com/en-us/download ... x?id=40784

I know it's a tough message to hear, but XP is 13 years old now. It only gets more difficult for software developers to maintain compatibility with such an old OS. Laptops capable of running Win7 comfortably are a cheap commodity these days.

That said, everyone should at least be running SP3. The GetLogicalProcessorInformation problem is because you're still on SP2. It's no longer possible for me to support SP2. Sorry.
***************************************
TunerPro Author
1989 Trans Am

SD16
Posts: 26
Joined: Wed Oct 19, 2005 3:43 am
Location: Deutschland

Post by SD16 » Thu May 15, 2014 9:19 am

With installation klappts with me also not!
If Tunerpro has installed, this runs! Tunerpro RT funktioniet not!

VassilisA
Posts: 3
Joined: Sun May 11, 2014 6:07 am

Post by VassilisA » Thu May 15, 2014 9:34 am

Thanks for your support Mark, you're doing a great job and of course are right about backwards compatibility and the headache caused to software developers.
However moving all other tuning software, utilities and mainly hardware to a Win7 laptop that usually doesn't have paraller/serial ports that are absolutely needed (at least to me) is not that easy at the time.

Unfortunately after installing that redist the problem remains the same "TunerPro... has encountered a problem and needs to close....'
Of course on SP3 and regarding TunerPro RT.

Any other info required for debugging I'd be more than willing to supply.

User avatar
Mangus
TunerPro Author
Posts: 1827
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Thu May 15, 2014 12:45 pm

VassilisA wrote: Unfortunately after installing that redist the problem remains the same "TunerPro... has encountered a problem and needs to close....'
Of course on SP3 and regarding TunerPro RT.

Any other info required for debugging I'd be more than willing to supply.
Go to Documents->TunerPro Files and delete all of the settings.dat files, then re-launch and report back the results.

Thanks!

(PS - chances are your current laptop would run Win7 reasonably)
***************************************
TunerPro Author
1989 Trans Am

User avatar
dex
The Ford Guy
Posts: 550
Joined: Thu Oct 07, 2004 6:38 am

Post by dex » Fri May 16, 2014 12:50 am

The Visual C++ Redistributable Package for Visual Studio 2013 is already installed on this particular pc.

Following XP SP3 installation I get a different error now; "error signature". Deleting the TunerPro setting .dat files did not appear to affect anything.

I know what you are saying about Windows XP being old but it was still being officially licensed by Microsoft and shipped on laptops upto and including 2010.

User avatar
Mangus
TunerPro Author
Posts: 1827
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Fri May 16, 2014 6:43 am

dex wrote:The Visual C++ Redistributable Package for Visual Studio 2013 is already installed on this particular pc.

Following XP SP3 installation I get a different error now; "error signature". Deleting the TunerPro setting .dat files did not appear to affect anything.

I know what you are saying about Windows XP being old but it was still being officially licensed by Microsoft and shipped on laptops upto and including 2010.
What's the signature that is specified? These types of messages generally have a series of numbers that follow them. Can you send the complete message text, please? You can usually activate the error window and hit Ctrl + C to copy the text.

It's 2014 (half again of XP's entire lifetime beyond the end of licensing).

-Mark (who happens to be sat in a Microsoft building)
***************************************
TunerPro Author
1989 Trans Am

VassilisA
Posts: 3
Joined: Sun May 11, 2014 6:07 am

Post by VassilisA » Sat May 17, 2014 1:32 am

Mangus wrote:
VassilisA wrote: Unfortunately after installing that redist the problem remains the same "TunerPro... has encountered a problem and needs to close....'
Of course on SP3 and regarding TunerPro RT.

Any other info required for debugging I'd be more than willing to supply.
Go to Documents->TunerPro Files and delete all of the settings.dat files, then re-launch and report back the results.

Thanks!

(PS - chances are your current laptop would run Win7 reasonably)
Deleted 'TunerProSettings.dat' and TPSPMSettings.dat' but the application is still not running giving the same 'TunerPro... has encountered a problem and needs to close....'

SD16
Posts: 26
Joined: Wed Oct 19, 2005 3:43 am
Location: Deutschland

Post by SD16 » Sun May 18, 2014 6:27 am

Hello

I have also tried to extinguish the settings file, brought, unfortunately, no success!
I have a Panasonik CF29 with Win XP SP3.
If I Tunerpro RT start the blue TunerproRT start screen appears, and below appears in a small line: Version 5 Detecting Hadware Build 5.00.8383.00.
This screen remains, and program does not start!
Does it can do his the program a certain Hadware looks? and this is not found.

Thanks
Greeting
SD16

User avatar
dex
The Ford Guy
Posts: 550
Joined: Thu Oct 07, 2004 6:38 am

Post by dex » Sun May 18, 2014 11:58 pm

I cannot copy the error report contents (Windows will not let me) so I have sent you a copy of the log that gets sent with the Windows error report.

User avatar
Mangus
TunerPro Author
Posts: 1827
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Tue May 20, 2014 5:47 pm

So far I've been unable to reproduce this on my two XP machines, so I'm not sure how to approach a fix. Any ideas?
***************************************
TunerPro Author
1989 Trans Am

SD16
Posts: 26
Joined: Wed Oct 19, 2005 3:43 am
Location: Deutschland

Post by SD16 » Tue May 20, 2014 8:20 pm

If they say to me please like I can help!
How can I ascertain where the mistake lies?

Thanks
Greeting
SD16

Avinitlarge
Posts: 12
Joined: Tue Jan 21, 2014 3:04 pm

Post by Avinitlarge » Fri Aug 01, 2014 7:00 am

I was running 8202 with not problems, upgraded to 8383, Just won't open.
Deleted the DAT files but still the same. Works fine on my 7 laptop, only reason I use the dell is, I have a car charger for it and I can't always use my other laptop as my daughter likes to use it
Dell C600 512mb RAM 700mhz CPU, XP SP3

Here is the error dump

Code: Select all

<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="TunerPro.exe" FILTER="GRABMI_FILTER_PRIVACY">
    <MATCHING_FILE NAME="ADXEditor.dll" SIZE="465408" CHECKSUM="0xBEAC04A9" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/01/2014 02&#58;55&#58;12" UPTO_LINK_DATE="05/01/2014 02&#58;55&#58;12" />
    <MATCHING_FILE NAME="MoatesOnboardLogger.dll" SIZE="361984" CHECKSUM="0x7CE8BCFD" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/01/2014 02&#58;55&#58;02" UPTO_LINK_DATE="05/01/2014 02&#58;55&#58;02" />
    <MATCHING_FILE NAME="msvcp100.dll" SIZE="421200" CHECKSUM="0x2A20605" BIN_FILE_VERSION="10.0.30319.1" BIN_PRODUCT_VERSION="10.0.30319.1" PRODUCT_VERSION="10.00.30319.1" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2010" FILE_VERSION="10.00.30319.1" ORIGINAL_FILENAME="msvcp100.dll" INTERNAL_NAME="msvcp100.dll" LEGAL_COPYRIGHT="© Microsoft Corporation.  All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x6CEB5" LINKER_VERSION="0xA0000" UPTO_BIN_FILE_VERSION="10.0.30319.1" UPTO_BIN_PRODUCT_VERSION="10.0.30319.1" LINK_DATE="03/18/2010 07&#58;53&#58;01" UPTO_LINK_DATE="03/18/2010 07&#58;53&#58;01" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
    <MATCHING_FILE NAME="msvcp120.dll" SIZE="455328" CHECKSUM="0x37EF115E" BIN_FILE_VERSION="12.0.21005.1" BIN_PRODUCT_VERSION="12.0.21005.1" PRODUCT_VERSION="12.00.21005.1" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2013" FILE_VERSION="12.00.21005.1 built by&#58; REL" ORIGINAL_FILENAME="msvcp120.dll" INTERNAL_NAME="msvcp120.dll" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x778ED" LINKER_VERSION="0xA0000" UPTO_BIN_FILE_VERSION="12.0.21005.1" UPTO_BIN_PRODUCT_VERSION="12.0.21005.1" LINK_DATE="10/05/2013 02&#58;43&#58;57" UPTO_LINK_DATE="10/05/2013 02&#58;43&#58;57" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
    <MATCHING_FILE NAME="msvcr100.dll" SIZE="770384" CHECKSUM="0x6C2B1057" BIN_FILE_VERSION="10.0.30319.1" BIN_PRODUCT_VERSION="10.0.30319.1" PRODUCT_VERSION="10.00.30319.1" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2010" FILE_VERSION="10.00.30319.1" ORIGINAL_FILENAME="msvcr100_clr0400.dll" INTERNAL_NAME="msvcr100_clr0400.dll" LEGAL_COPYRIGHT="© Microsoft Corporation.  All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xC53CC" LINKER_VERSION="0xA0000" UPTO_BIN_FILE_VERSION="10.0.30319.1" UPTO_BIN_PRODUCT_VERSION="10.0.30319.1" LINK_DATE="03/18/2010 07&#58;52&#58;30" UPTO_LINK_DATE="03/18/2010 07&#58;52&#58;30" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
    <MATCHING_FILE NAME="msvcr120.dll" SIZE="970912" CHECKSUM="0xC7FFB849" BIN_FILE_VERSION="12.0.21005.1" BIN_PRODUCT_VERSION="12.0.21005.1" PRODUCT_VERSION="12.00.21005.1" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2013" FILE_VERSION="12.00.21005.1 built by&#58; REL" ORIGINAL_FILENAME="msvcr120.dll" INTERNAL_NAME="msvcr120.dll" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xFB320" LINKER_VERSION="0xA0000" UPTO_BIN_FILE_VERSION="12.0.21005.1" UPTO_BIN_PRODUCT_VERSION="12.0.21005.1" LINK_DATE="10/05/2013 02&#58;43&#58;50" UPTO_LINK_DATE="10/05/2013 02&#58;43&#58;50" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
    <MATCHING_FILE NAME="PromIO.dll" SIZE="292352" CHECKSUM="0xA6F7A133" BIN_FILE_VERSION="1.0.3849.1" BIN_PRODUCT_VERSION="1.0.0.1" PRODUCT_VERSION="1, 0, 0, 1" FILE_DESCRIPTION="Moatesware Prom IO Library" PRODUCT_NAME="Moatesware Prom IO Library" FILE_VERSION="1, 0, 3849, 1" ORIGINAL_FILENAME="PromIO.dll" INTERNAL_NAME="Moates Prom IO" LEGAL_COPYRIGHT="Copyright &#40;C&#41; RusnaMark SW" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.0.3849.1" UPTO_BIN_PRODUCT_VERSION="1.0.0.1" LINK_DATE="05/01/2014 02&#58;54&#58;46" UPTO_LINK_DATE="05/01/2014 02&#58;54&#58;46" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
    <MATCHING_FILE NAME="ScannerProModule.dll" SIZE="426496" CHECKSUM="0x46630C9C" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/01/2014 02&#58;55&#58;07" UPTO_LINK_DATE="05/01/2014 02&#58;55&#58;07" />
    <MATCHING_FILE NAME="TPChecksumPlugin.dll" SIZE="16384" CHECKSUM="0xE2E006E6" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/01/2014 02&#58;54&#58;36" UPTO_LINK_DATE="05/01/2014 02&#58;54&#58;36" />
    <MATCHING_FILE NAME="TPMoatesEmulatorPlugin.dll" SIZE="60416" CHECKSUM="0xB6C343A6" BIN_FILE_VERSION="1.0.0.1" BIN_PRODUCT_VERSION="1.0.0.1" PRODUCT_VERSION="1, 0, 0, 1" FILE_DESCRIPTION="Moates &amp; XTronics Device Plugin for TunerPro" COMPANY_NAME="RusnaMark Software" PRODUCT_NAME="Moates &amp; XTronics Device Plugin for TunerPro" FILE_VERSION="1, 0, 0, 1" ORIGINAL_FILENAME="TPMoates.dll" INTERNAL_NAME="TPM.dll" LEGAL_COPYRIGHT="Copyright &#40;C&#41; RusnaMark Software" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.0.0.1" UPTO_BIN_PRODUCT_VERSION="1.0.0.1" LINK_DATE="05/01/2014 02&#58;54&#58;38" UPTO_LINK_DATE="05/01/2014 02&#58;54&#58;38" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
    <MATCHING_FILE NAME="TunerPro Motronic 4.4 CheckSum.dll" SIZE="7680" CHECKSUM="0x9E5D1CF3" MODULE_TYPE="WIN32" PE_CHECKSUM="0x88AF" LINKER_VERSION="0x0" LINK_DATE="03/20/2013 02&#58;52&#58;49" UPTO_LINK_DATE="03/20/2013 02&#58;52&#58;49" />
    <MATCHING_FILE NAME="TunerPro.exe" SIZE="1093632" CHECKSUM="0x7299ED59" BIN_FILE_VERSION="5.0.8383.0" BIN_PRODUCT_VERSION="5.0.0.0" PRODUCT_VERSION="5, 0, 0, 0" FILE_DESCRIPTION="TunerPro - Automobile Tuning and Diagnostic Software" COMPANY_NAME="Creational Technologies, LLC" PRODUCT_NAME=" TunerPro Application" FILE_VERSION="5, 0, 8383, 0" ORIGINAL_FILENAME="TunerPro.exe" INTERNAL_NAME="TunerPro" LEGAL_COPYRIGHT="Copyright &#40;C&#41; Creational Technologies, LLC - All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="5.0.8383.0" UPTO_BIN_PRODUCT_VERSION="5.0.0.0" LINK_DATE="05/01/2014 02&#58;55&#58;52" UPTO_LINK_DATE="05/01/2014 02&#58;55&#58;52" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
    <MATCHING_FILE NAME="unins000.exe" SIZE="715253" CHECKSUM="0x30FA562F" BIN_FILE_VERSION="51.52.0.0" BIN_PRODUCT_VERSION="0.0.0.0" FILE_DESCRIPTION="Setup/Uninstall" FILE_VERSION="51.52.0.0" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x60000" UPTO_BIN_FILE_VERSION="51.52.0.0" UPTO_BIN_PRODUCT_VERSION="0.0.0.0" LINK_DATE="06/19/1992 22&#58;22&#58;17" UPTO_LINK_DATE="06/19/1992 22&#58;22&#58;17" VER_LANGUAGE="Language Neutral &#91;0x0&#93;" />
    <MATCHING_FILE NAME="XDFEditor.dll" SIZE="526336" CHECKSUM="0x1F518A98" BIN_FILE_VERSION="2.0.3801.1" BIN_PRODUCT_VERSION="1.0.0.1" PRODUCT_VERSION="1, 0, 0, 1" FILE_DESCRIPTION="XDF Definition File Editor" PRODUCT_NAME="XDF Definition File Editor" FILE_VERSION="2, 0, 3801, 1" ORIGINAL_FILENAME="XDFEditor.dll" INTERNAL_NAME="XDF Editor" LEGAL_COPYRIGHT="Copyright &#40;C&#41; RusnaMark SW" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="2.0.3801.1" UPTO_BIN_PRODUCT_VERSION="1.0.0.1" LINK_DATE="05/01/2014 02&#58;55&#58;12" UPTO_LINK_DATE="05/01/2014 02&#58;55&#58;12" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="kernel32.dll" SIZE="993280" CHECKSUM="0x599F4100" BIN_FILE_VERSION="5.1.2600.6532" BIN_PRODUCT_VERSION="5.1.2600.6532" PRODUCT_VERSION="5.1.2600.6532" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.6532 &#40;xpsp_sp3_qfe.140312-0419&#41;" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xF63D5" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.6532" UPTO_BIN_PRODUCT_VERSION="5.1.2600.6532" LINK_DATE="03/12/2014 10&#58;48&#58;50" UPTO_LINK_DATE="03/12/2014 10&#58;48&#58;50" VER_LANGUAGE="English &#40;United States&#41; &#91;0x409&#93;" />
</EXE>
</DATABASE>

SD16
Posts: 26
Joined: Wed Oct 19, 2005 3:43 am
Location: Deutschland

Post by SD16 » Tue Aug 12, 2014 2:17 am

Hello

I think I have found with myself fehler!
If AdwCleaner let about that run, and TunerPro RT runs again!
Thanks
Greeting
SD16

User avatar
Mangus
TunerPro Author
Posts: 1827
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Sat Jan 17, 2015 5:17 pm

Those of you who are seeing this problem, can you confirm that you've taken all of the Windows updates that are available, and that you're running the latest version of Internet Explorer available? I'm thinking this is a result of one or more OS components not being the latest available. (IE is used by the OS as well, since IE updates cause updates to the common controls.)
***************************************
TunerPro Author
1989 Trans Am

lorenfb
Posts: 2
Joined: Mon May 25, 2015 9:58 am

Post by lorenfb » Mon May 25, 2015 10:26 am

Mangus wrote:Those of you who are seeing this problem, can you confirm that you've taken all of the Windows updates that are available, and that you're running the latest version of Internet Explorer available? I'm thinking this is a result of one or more OS components not being the latest available. (IE is used by the OS as well, since IE updates cause updates to the common controls.)
I fully updated WinXP to all SP3 updates and still the app provides the same
error message as has been posted by Avinitlarge on my IBM T23. My T30
had WinXP SP3 and the app ran with no problem. My T40 had only SP2 and
developed the kernel32.dll error. So the T40 was updated to SP3 and the
app ran.

The problem may be the result of the older processor in the T23, i.e. a long
shot guess:

T23 - Pentium III 1.13GHz, 512MB RAM
T30 - Pentium 4-M 1.9Ghz, 512MB RAM
T40 - Pentium M 1.5 GHz, 1.25GB RAM

Is it possible to make available an older version that ran on the older machines?
Would be great if this issue could be resolved one way or another, e.g. only
functional on XP machines with later processors.

If necessary, the laptop (IBM T23) can be supplied to TunerPro for analysis.

User avatar
Mangus
TunerPro Author
Posts: 1827
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Mon May 25, 2015 7:38 pm

Sorry guys, I wish I had a better answer for you, but without being able to reproduce this, it's impossible for me to narrow it down to a cause that I can fix.

Old versions are still available for download. change the XXXX part in the link to the build # you want:

http://www.tunerpro.net/downlaod/SetupT ... 0_XXXX.exe

http://www.tunerpro.net/downlaod/SetupT ... 0_XXXX.exe
***************************************
TunerPro Author
1989 Trans Am

lorenfb
Posts: 2
Joined: Mon May 25, 2015 9:58 am

Post by lorenfb » Tue May 26, 2015 8:52 am

Mangus wrote:Sorry guys, I wish I had a better answer for you, but without being able to reproduce this, it's impossible for me to narrow it down to a cause that I can fix.

Old versions are still available for download. change the XXXX part in the link to the build # you want:

http://www.tunerpro.net/downlaod/SetupT ... 0_XXXX.exe

http://www.tunerpro.net/downlaod/SetupT ... 0_XXXX.exe
The older versions work fine on my IBM T23. Still would like to understand
what the problem is with the later version. It has to be something that's
been basically over looked, i.e. compared all the files of both T23 & T40
and both are the same.

User avatar
Mangus
TunerPro Author
Posts: 1827
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Tue May 26, 2015 9:21 am

What changed between versions is an update from Visual Studio 2012 to Visual Studio 2013, thus introducing a new set of dependencies. One or more of those dependencies must be causing a problem, perhaps tied to CPU extension support. I'll continue to investigate as I have time, but I can't consider this a high priority given that XP is 15 years old.
***************************************
TunerPro Author
1989 Trans Am

Post Reply