Page 2 of 2

Re: M3.3.1 413

Posted: Wed May 15, 2019 10:46 am
by Triangulé
congratulation JAS and thanks for the numbers you share with us.

Can you let me know what kind of AFR you are targetting for WOT ?
At our side the engine was runing good at 12 for low boost (0.35 to 0.45 b) and request more than 11 to 10 with now 0.8 bars.

Witch revision of AUTOCOM do you use ?
We have the old round 20 pins diag plug, it's hard to find a software that didn't need a serial adaptator, we need to change our software.
I have inpa, that is running good on my M54b30 but not helpfull for the M50.

Now your car is running good.
You need to check the injector duty cycle to see how do you use your injectors, and where you are located on the scale of their limits.
Next step will be to avoid air leak on the inlet, step by step they will appear :)

thanks Olafu again and again :)
Your bless :)

I will cut my MAF maps in 2 smaller one to check that again.

Re: M3.3.1 413

Posted: Wed May 15, 2019 11:28 am
by JAS
You´re right,TunerPro can´t trace maf above 2,44V
I traced it with Autocom instead.

I haven´t rescale anything but K-value.My calculated K-value should be around 0,36 but this makes low values on Load,so my solution was to set K-value 0,75 so load is peaking about 9,6,this gives me the whole maptable for Load to work with.Works fine.

I have tried to replace bleedingvalve with a solid plug for oilpressure in the tranny,it shifted hard as hell with a minimum with slip!!But it also shifts hard as hell when slowing down and shifting at cruisingspeed,no good allround solution...
It shifts pretty good when car is cold with bleedingvalve instead of plug.

Problemm is only present when shifting upp or down to third gear,it freerevs before gear is engaged.

if I could adjust oilpressure by software it will be the solution,adjust oilpressure load-depending.

Re: M3.3.1 413

Posted: Fri May 17, 2019 1:07 am
by JAS
Autocom R15.3 works fine with old cars such e36.

AFR is 12-12,5 at WOT,if it drops under 12 I´m loosing power,also pay attention due to much fuel,oil inside cylinderwalls is washed away.

Found out that problem with A/T Tranny is a common problem,there is a "2-3 Flare correction kit" to buy,it´s probably going to solve my problem.So cool with A/T,when shifting the boost is rock steady!No drop of all!

Is it possible to check injector duty in TunerPro?

Re: M3.3.1 413

Posted: Fri May 17, 2019 7:49 am
by Triangulé
i don't think you can check the duty cycle % in tunerpro.
You have to take the scope or even a good multimeter than can make the measurement of frequency and dutycycle.
Some automotive multimeter can do it, anyway digital scope are really abordable nowadays.

thanks for sharing your results

Re: M3.3.1 413

Posted: Sat May 18, 2019 12:31 pm
by JAS
There is a scope called picoscope you can use on a laptop,don´t know what the cost just know we used them in a former jobb Ihad 10 years ago.
Anyway,I´m giving up petrol now...10,5:1 compratio and boosted engine is not performing well,it still keeps knocking,not much but enough...
Going to try E85 etanol,better fuel for boosted applications.
Will let you know the result!

Do not belive what they say about alcohol,I´m sure alcohol will solve all my problems :twisted:

Re: M3.3.1 413

Posted: Sun May 19, 2019 12:33 am
by Triangulé
there's some alternative with the chineses DSO series.
As all moderne engine have electronics sensors, a portable scope is a good investment.
even to repair or found the speed frequency signal, check ECU. it's a must tool to have.
I have an Hantek 1060, it's small enough to bring it in the car during the drive tests.

10.5 CR is too much for 0.8 bars.
You should reduce a little bit the pressure or as you said go to Ethanol.

We also have the plan to switch to E85, because it's cheaper for a track day use.
currently with the full tank we are able to do around 120km and no more ...

Re: M3.3.1 413

Posted: Sun May 19, 2019 12:43 am
by JAS
E85 is not cheaper to run,it´s only cheaper per liter but car wants about 30-40% more fuel...But cheaper peroformance,my friend told me that they are pulling about 20% more horsepower&Torque on E85 vs gasoline.Also lots easier to map...

Re: M3.3.1 413

Posted: Sun May 19, 2019 10:54 am
by JAS
Been tuning&running today.
With E85 you can advance ignition a lot!Peaking around 24degrees 5-6krpm in WOT-maps now.
It requires a lot more of fuel to reach AFR11,5-12.

Car pulls fantastic now,no hesitate just pulls down to rpm-limit,massive torque from 3k rpm and above.

Have to run with Lambda-adaption off,otherwise it leans out.

Do anybody know if it´s possible to turn off adation above 2krpm?

Re: M3.3.1 413

Posted: Sun May 19, 2019 1:41 pm
by olafu
6x1 map in 0xE35C (0xE364-E369) is lambda control switch off load limits. It follows RPM and if actual load is higher than map value, closed loop will be switched off. If you have been adjust K-value, that is one of many maps what must be rescaled. 0xE36A, 0xE378 and 0xE382 are also called lambda switch off maps, but i'm never tried to adjust any of those four maps.

Re: M3.3.1 413

Posted: Sun May 19, 2019 8:08 pm
by JAS
Thanks for info Olafu!

Re: M3.3.1 413

Posted: Thu May 23, 2019 3:45 am
by Triangulé
Hi JAS,

Can you please confirm that you can read 100% of the LIVE DATA with AUTOCOM on your M50.
It's a 20 pin round connector using ADS protocole ?

I try to do it with Carsoft but i can only diagnose the ecu not read live data.

Thanks

Re: M3.3.1 413

Posted: Thu May 23, 2019 7:56 pm
by JAS
No problem to read livedata with autocom,connected to 20pin round.

Very useful to read actual igntion no matter what igntiontable DME is reading,also no matter knockretarding.Autocom will show you realtime ignition.
Without autocom youre blind and you will only be guessing ignition!

Re: M3.3.1 413

Posted: Fri May 24, 2019 4:08 am
by Triangulé
thanks for your feedback.
we plan to use INPA to monitor in live the sensors, my friend just ordered the ADS interface.
I will buy the AUTOCOM if this is not working.

Today we used the ostrich for a live mapping session.
First thing we had to change the full set of igniton coils that have burnt on the last track session.
It's impressive to see how the engine is now running more smoothly, i think the original coils were probably tired from a long long time ...
not easy to check those COP coils, 27 years old coil ... it's like sending my grand mother for racing.
So we have decided to change the full coils for a better performance set (brand HP iGNITON), they work nicely.

Datas U5012 HP IGNITON :
max output current: 11.2A
Max output voltage: 42KV
Dwell Max. 5ms

Now, our main problem is that the engine is too rich after 6000 rpm.
The ecu don't wan't to switch to the WOT maps, it stay on the PT map.
Or maybe there is no tracing on the WOT map, but i have try to reduce the values and AFR still the same.

I wonder if the problem is not coming from :
_ the throttle potentiometer. checked with a scope, it is working, but don't know how the ecu is seen this signal.
_ PT to WOT map switch. Olafu gave me the address, but the tracing behaviour is really strange. i's probably based on the Load, as it is modifyed, Is the ecu able to switch ...
_ MAF is over is limit, and could generate some wrong value ? (for the AFR)

Another question.
tuner pro Tracking is not fast enough. is there anything to do to refresh the plot faster ?


Any other idea guys ?

Re: M3.3.1 413

Posted: Fri May 24, 2019 11:41 am
by JAS
Tunerpro do not trace WOT maps!
Trace PT maps and when tracing light turns to "waiting" you should be in WOT map if everything is ok eg not MAF over limit and so on.

I forgott to turn off Lambda adaption,3 full WOT sweeps on third gear resulted in lean mixture,aboyt 14,5 on WOT.Now I have lost aboyt 4kg of comprssion on 6th cylinder :oops:
Probably cracked piston between rings..Still runs pretty good...

All cylinder are around 12-12,5 kg compression,6th cylinder is about 8-8,5...

Re: M3.3.1 413

Posted: Sat May 25, 2019 1:55 am
by olafu
I don't surely know, but WOT maps are propably in use only with closed loop active. Or something else will block it.
And about those lambda off maps, you must to clear out how it works, i can't help. Never tried to adjust them, only played with them by test.

Re: M3.3.1 413

Posted: Mon May 27, 2019 2:00 am
by Triangulé
hi guys

thanks Olafu for your feedback, this look coherent.
There is no reason to have a WOT map if we unplugged the lambda probe.
I'm curious to know if the "02 off check box" in the XDF is normal function of the ECU, i mean if it have been plan as a function by bosch ?
Or is the xdf modifying a general value filtering the other lambda maps ?

on another plan, i try to understand how work the VANOS switching.
Seems that you said some maps are throttle related.
It's probably related to the how fast the throttle move or something like that ?
It's look like an hysteresis but I think it's not.
I can see the advanced and retarded curve have the same high value 255.
If it was a simple rpm hysteresis, it will be impossible for the ECU to know witch map to select.

As i have change all the load rescaled value, seems that also need to be corrected.
Also as our turbo is charging around 3200 rpm, i think we can switch to the avanced mode sooner than the original switching point.
I don't know if modifying the scale of the VANOS load related map could change the switch point. (max 4500 rpm)


Hi JAS,

I'm sorry for your engine.
Are you sure this is a ring or piston trouble ?
Original head gasket are not really made for such high power and high compression turbo charging.
But if your engine is not smoking, i would be worry also.
Our compression is around 10.8 to 11 engine cold with no open throttle and no oil on the pistons.

Turbocharging is killing all the weak parts step step ...

Re: M3.3.1 413

Posted: Mon May 27, 2019 3:27 am
by JAS
Quite sure that headgasket is not my problem,there is no smoke,only less compression and more crankvent.
started to tear engine apart yesterday,so soon you will have an answer.

Vanos is swithing to advance somewhere about 1800rpm and back to retard about 5k related to load.I can see very clearly on AFR,if map for Fuel retarded vanos is a bit lean AFR rises about 5krpm.

With lambda adaption off WOT maps are not effecting anything only PT maps,been testdriving a lot and no matter what value in WOT maps it won´t effect ignition or AFR.
I´m not going to run with lambda adaption active anymore,it costed me 1piston a lots of extrawork...

Re: M3.3.1 413

Posted: Mon May 27, 2019 10:37 am
by Triangulé
Hi JAS,

Ok keep us informed.
I hope you could provide some pictures, pistons, rings, head and plugs also.
We could try to diag all together what happen and learn from this bad experience.
The good point is that you can now buy a thicker headgasket to push a little bit more the pressure safely.
good luck to you.

About the VANOS, do you know if the VANOS is going back to Advanced at the top end, just before the rev limiter (around 6.5k).
Alfa use this way on their engines to slow down the rev's close to the rev limiter.
The bad thing is that is limiting the power at the top end even if we push the rev limiter.
So i don't know about the m50 if the german engineer did it this way.

Re: M3.3.1 413

Posted: Mon May 27, 2019 9:46 pm
by JAS
I found a diagram somewhere of Vanos related to rpm/load,but i can´t find now...
Vanos stays in retard the whole way after ~5k rpm.

Will post some pics later,pulled head of yesterday.Gasket and head looks nice,no knockingmarks on pistons.Sure there is a crack on piston between rings perhaps even cracked rings.
Quite sure this is because less cooling at cyl6 and to tight ringgap for boosted application.

The plan is to put an oem gasket back and new headbults.
There is no problem running up to 1 bar boost with oem gasket and bolts,boostpressure is not killing gasket,to high cylpressure will kill it,due to knocking causing extreme cylpressure.

Edit,Found a document explaining fuel maps.WOT maps are not actually values,they are correction factors.128 means 0 correction!Lets say you have 110 in top for PT-maps,WOT map will need to be above 128 for more fuel!Intresting and this may explain why not WOT maps are responding.

Re: M3.3.1 413

Posted: Wed May 29, 2019 11:59 pm
by olafu
Looks like those wot maps needs :
- closed loop must be enabled (0xD00B bit2)
- engine must be run in closed loop for a while.. few minutes?
- throttle position goes over "WOT" switchpoint (WOT switchpoint table is in 0xD540-D543. RPM axis is hard coded in program. Table values are TPS raw values)

WOT fuel map is similar correction as PT and IDLE maps. Referred to 128 "~no correction": 255 "~injection time*2" 64 "~injection time*0.5" not exactly, but roughly.

Re: M3.3.1 413

Posted: Thu May 30, 2019 11:58 pm
by JAS
Thanks for your superior info olafu,very useable!

Have teared apart engine now and it was like suspected.2 cracks betwwen pistonrings.

Picked up and started to prepare 6pcs of NonVanos pistons and rods,gonna to setup with new pistonrings.Ringgap will be set to 0,5mm on upper ring and 0,6 on lower compressionring

Will post some pictures some day.

Re: M3.3.1 413

Posted: Tue Jun 11, 2019 11:00 pm
by JAS
Work in progress,delayed by Sweden Rock Festival :twisted:

A new headbult-stud messed up my threads in the block....no more cheap crapy bolts...Drilled and installed Heli-coil insert

Pistons and rods are installed,this configuration gives 10:01 instead of 10,5:1 compression.
New 2mm headgasket,kind like cooperring.0,5mm thicker than oem,lowerd comp-ratio.
ARP-studs för head.

This improvements will allow more boost but injectors and my autotranny is limiting me.Hope injectors are able to deliver fuel for 1-1,2bar boost.If they do the tranny is at it´s very limit..

Re: M3.3.1 413

Posted: Mon Jul 08, 2019 8:17 pm
by JAS
Update

Have now been running and testing a while with the new setup.

Had some problems keeping boost,boost was falling off above 4,5k rpm...
Solution to prevent boostfall was to feed wastegate from manifold,not from turbohousing.Also added a "Dawes device" which only allows pressure to wastegate when right amount of boost is achived,bleeding wategate is a bad idea and results in unstable boost.
Now running boost at 1,1bar peaking and 1 bar att full rpm.
Ignition is about 22 degrees at top and afr around 11-12 at full load.
Load-value is peaking 9,45 and 1040kg/h with air,logged with autocom.

Car is running great,really smooth before boost is coming.Just like it was as standard before and with boost it´s a beast.
Massive torque and power.Auto-tranny is doing great,no slipping or flair when gearing up.A little bit of ruff down-shifting sometimes but fully acceptable.
I´m intrested in to figure out how tranny communicates with Motronic,have done some mechanically tweaks in tranny but I think this can be adjusted in software,just need to figure out how...

Will run with this setup for rest of the summer.

If someone wants my bin-file just let me know.

My turbo is damaged,pushing out oil in exhaust due to a bad oilreturn-hose.Just ordered 2pcs of new turbos!

Re: M3.3.1 413

Posted: Mon Jul 15, 2019 6:35 am
by JAS
Turbo is by now replaced.
Bought a Link knockblock,conntected to knocksensor I can hear sounds from engine,knocking,even small knockings are heared very clearly.
Great tuning tool!

Re: M3.3.1 413

Posted: Thu Jul 18, 2019 6:45 am
by Triangulé
Quite happy to read your happy end story !

and nice to see another great project running.

do you run E85 or did you came back to 98 ?

link blockknock look great tool. thanks for the feedback.

Dawes device. I just add a look.
It seems to help the wastegate to close better at low under the boost pressure ? right ? so it help spooling faster ?


At our side the car run very well also.
We have change all the tires for Michelin pilot sport 2.
they have been made for Porsche, and it's totally a different chassis now.
It's maybe the best investment made on this old chassis.
now you can really play with the power.
this summer we will go for a LSD final gear, and also a little longer ratio final gear.
Now with the current FG can, the car can reach 210km/h, and we plan to have it 7 to 10% more.
this will maybe need to push the turbo to 1bar, as we still at 0.8.

Also oil radiator is plan ... lot of work again.

Re: M3.3.1 413

Posted: Wed Jul 24, 2019 11:27 am
by JAS
No,still running E85,gasoline sucks in comparsion.Running 10-12 degrees higher igntion with e85 than gasoline.

Dawes device makes turbo spool faster because there is no pressure ro wastegate until desired pressure is reached.Taking pressure from turbos compressorhousing to wastegate is the worst sollution,That means wastegate is opening when desired boost is reached in turbo and not in manifold!

I take mine boostcontrol from manifold,connected to Dawes device and then to wastegate.Works great!

Last thing to sort out is oilfeed to/from turbo...
Running lowmount turbo,had some problem with poor returnoilfeed from turbo,turbo is very low,only 5cm fallheight for oil.

Suspecting my big olifeed to turbo is giving a little to much oil,,have done a smaller new restrictor,bigger returnpipe but it still bluesmokes...

Going to try AN4 oilfeed.

Re: M3.3.1 413

Posted: Thu Oct 24, 2019 9:07 pm
by JAS
Project update!

Plans for 2020,
Going for Motronic even next year,my autotranny is does not work without Motronic,not yeat :wink:
Also adding an Ecumaster DET3 with 4bar mapsensor,DET3 makes it possible to delete the MAF and it converts the MAP-signal to a MAF-signal.
DET3 is planned to handle ignition and "MAF" but Motronic is still controlling fuel.
Another thing try try is to lead "load"-signal from Motroninc to trannys TCU thru DET3 and test to modify signal and see how tranny is behaving.Have tried this with TunerPro but tranny is not responding as I thought.
Stroking engine from 2,5 to 2,8l
Precision 5558 or similar turbo
Siemens 675cc injectors.
Rebuilding autotranny with twice as much friction plates in all 6 clutchbaskets.