Using Scannerpro

For those of you brave enough to try the beta releases, please ask your questions and post your issues here! Remember, the more info the better!

Moderators: robertisaar, dex

Locked
kirkm
Posts: 5
Joined: Sun Jul 22, 2007 6:01 am

Using Scannerpro

Post by kirkm » Tue Jul 24, 2007 4:04 pm

Mark,

I tried to use scanner pro on my 1995 corvette A4 using EE stream version 0.5 and could not get a constant connection. Lots of errors showing up with constant flickering of the connection status. I am using a Moates Xtreme ALDL USB with a 1.6Ghz dual core Turion laptop. It is working well with Datermaster.

Is there a way to setup Scannerpro to dump the raw serial data dialog to see the PCM to computer chatter? I am willing and somewhat able to figure out what is going on. I do not really know the ALDL dialog but have been looking at the A223 definition.

Kirk

kirkm
Posts: 5
Joined: Sun Jul 22, 2007 6:01 am

Some sample output questions

Post by kirkm » Wed Jul 25, 2007 3:19 pm

Below is output I see from ScannerPro. I am trying to get an udnerstanding of what is going on.

What does the Command Failure 0x000000006 indicate? Are each of the Macro Sequences a Monitor Macro Instance? Are MonitorMacro macros called continuously while connected? Is there any delay between calls.

Thanks,

Kirk

BEGIN MACRO
Looking for chatter...
CHATTER NOT FOUND
0.176: Command/Reply Success
0.272: Command/Reply Success
END MACRO
BEGIN MACRO
0.404: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
0.492: Command/Reply Success
END MACRO
BEGIN MACRO
0.622: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
0.700: Command/Reply Success
END MACRO
BEGIN MACRO
0.826: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
0.902: Command/Reply Success
END MACRO
BEGIN MACRO
1.029: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
1.122: Command/Reply Success
END MACRO
BEGIN MACRO
1.232: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
1.314: Command/Reply Success
END MACRO
BEGIN MACRO
1.372: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
1.435: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
1.554: Command/Reply Success
1.632: Command/Reply Success
END MACRO
BEGIN MACRO
1.744: Command/Reply Success
1.841: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
1.965: Command/Reply Success
2.044: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
2.155: Command/Reply Success
2.248: Command/Reply Success
END MACRO
BEGIN MACRO
2.386: Command/Reply Success
2.435: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
2.562: Command/Reply Success
2.641: Command/Reply Success
END MACRO
BEGIN MACRO
2.769: Command/Reply Success
2.826: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
2.945: Command/Reply Success
3.044: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
3.160: Command/Reply Success
3.242: Command/Reply Success
END MACRO
BEGIN MACRO
3.370: Command/Reply Success
3.419: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
3.482: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
3.576: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
3.669: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
3.754: Command/Reply Success
END MACRO
BEGIN MACRO
3.869: Command/Reply Success
3.949: Command/Reply Success
END MACRO
BEGIN MACRO
4.068: Command/Reply Success
4.164: Command/Reply Success
END MACRO
BEGIN MACRO
4.263: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
4.356: Command/Reply Success
END MACRO
BEGIN MACRO
4.404: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
4.513: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
4.670: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
4.756: Command/Reply Success
END MACRO
BEGIN MACRO
4.878: Command/Reply Success
4.974: Command/Reply Success
END MACRO
BEGIN MACRO
5.076: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
5.165: Command/Reply Success
END MACRO
BEGIN MACRO
5.277: Command/Reply Success
5.357: Command/Reply Success
END MACRO
BEGIN MACRO
5.482: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
5.591: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
END MACRO
BEGIN MACRO
5.685: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
5.773: Command/Reply Success
END MACRO
BEGIN MACRO
5.887: Command/Reply Success
5.967: Command/Reply Success
END MACRO
BEGIN MACRO
6.092: !!!!!!SEND COMMAND FAILURE (0x00000006)!!!!!!
6.175: Command/Reply Success

User avatar
Mangus
TunerPro Author
Posts: 1827
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Sat Jul 28, 2007 2:05 pm

What I would recommend is that you remove the message 2 command from the monitor macro. This is probably what is causing the rror.

Change the monitor command to be the Mode 1 message 0 dump command in the ADX file.
***************************************
TunerPro Author
1989 Trans Am

Locked