Who Needs An ADS or ADX?

Discuss General Motors (GMC, Chevy, Pontiac, Hummer, Cadillac, etc) tuning topics here. Request definitions, discuss parameters, etc.

Moderators: robertisaar, dex

Post Reply
User avatar
SCReatta
Posts: 7
Joined: Tue Nov 11, 2014 8:07 pm

Post by SCReatta » Sat Nov 22, 2014 10:52 am

So I am guessing by this point that it is a no go on the help?
1989 Buick Reatta with a Series III supercharged 3800 bolted to a F40 six speed transmission

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Sat Nov 22, 2014 3:39 pm

I've had a LOT of personal stuff to deal with lately... lymphoma is a hell of a ride, and I'm not even the one that had it. :(

I'll try and get to it tonight, I've got a lot more free time on my hands now than I have had for the past couple months.

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Sat Nov 22, 2014 6:49 pm

the ECM portion of A072 is nearly identical to A094, so that file shouldn't take too long to get functional. it looks like there might be a typo or two that will need testing, like the A072 document claiming that the ECM's ID is 4F instead of F4.... I don't know if I've ever seen an application that uses 4F, but I've seen plenty that use F4.

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Sat Nov 22, 2014 8:12 pm

https://www.dropbox.com/s/g4h6gc2sjv9wwxj/A072.zip?dl=0

here is a ZIP containing 4 files, 2 are for TP V4, 2 for TP V5. the way these early 3800 PCMs communicate is certainly different. the document states the way they connect includes responding to a message sent out to an ALDL device, which will stop normal communications going to and from the BCM. if that is the case..... it will be difficult to do with V4 other than spamming that command out and hoping you get it into the window the ECM is looking for.

with V5, you can monitor for the message from the ECM, then send back the correct one immediately.

however... I don't know which device ID I need to setup the command for, so I put 4 of them in each file(4F, F0, F1 and F4). the difference between the two files(for V4 or v5) is that one is setup to communicate with a "4F" module, while the other is setup for "F4". one of them should get valid data from the ECM, the other shouldn't.

User avatar
SCReatta
Posts: 7
Joined: Tue Nov 11, 2014 8:07 pm

Post by SCReatta » Sun Nov 23, 2014 5:11 pm

Thank you for the help. With this not being a very popular application I figured that it would be forgotten about.
I tried the two V5 files, both seemed to communicate somewhat, but the data looked off. I am not sure what the best way to give you feed back on the definitions is. I recorded a short log file for each so to give an idea what the data return is. Please let me know if there is a better way to give you feed back or if there is other information needed.

https://www.dropbox.com/s/ss4u3mgfw3cms ... 4.zip?dl=0
1989 Buick Reatta with a Series III supercharged 3800 bolted to a F40 six speed transmission

User avatar
SCReatta
Posts: 7
Joined: Tue Nov 11, 2014 8:07 pm

Post by SCReatta » Wed Dec 03, 2014 6:37 pm

any luck on this or advise?
1989 Buick Reatta with a Series III supercharged 3800 bolted to a F40 six speed transmission

User avatar
Mangus
TunerPro Author
Posts: 1825
Joined: Wed Mar 19, 2003 1:49 pm

Post by Mangus » Mon Dec 08, 2014 9:46 am

The ALDL line on this vehicle has a body control module on it, and the command/response flow is a bit different form other vehicles.

The first thing the definition needs to do is listen for the F0 poll command. Details:

MESSAGE CODE $F0 IS USED BY THE ECM TO POLL FOR THE PRESENCE
OF AN ALDL TESTING DEVICE. IT IS TRANSMITTED FROM THE ECM
WITH THE FOLLOWING FORMAT

- MESSAGE CODE = $F0
- MESSAGE LENGTH
- SUM CHECK


IF AN ALDL DEVICE IS PRESENT, IT WILL RESPOND WITH THE FOLLOWING
MESSAGE:

- MESSAGE CODE = $F0
- MESSAGE LENGTH = 85 + 0 = 85 = $55
- SUM CHECK

ONCE IN ALDL MODE, THE ECM WILL CEASE TRANSMITTING THE NORMAL
MODE MESSAGES ($0A, $05).


For good measure, the definition can send a silence command on the line to quiet the BCM before it can get clean comms from the ECM. It's not entirely clear what the BCM's device ID will be for your vehicle, however.

Once the ECM is in ALDL mode, you can request a normal mode 1 message.

MODE 1 (TRANSMIT FIXED DATA STREAM)
ALDL REQUEST:
- MESSAGE ID = $F0
- MESSAGE LENGTH = $56
- MODE = $01
- SUM CHECK


My guess from looking at the logs is that you're seeing cross-talk on the ALDL line.
***************************************
TunerPro Author
1989 Trans Am

IDcavy93
Posts: 7
Joined: Tue Oct 07, 2014 4:33 am

Post by IDcavy93 » Mon Dec 22, 2014 5:29 am

robertisaar wrote:I've had a LOT of personal stuff to deal with lately... lymphoma is a hell of a ride, and I'm not even the one that had it. :(

I'll try and get to it tonight, I've got a lot more free time on my hands now than I have had for the past couple months.
I'm really sorry to hear that you went through that. You and your family/friends are in my prayers!

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Thu Dec 25, 2014 12:16 pm

yahoo started sending tunerpro notification emails into my spam folder... never realized when there were updates. :(
Mangus wrote: My guess from looking at the logs is that you're seeing cross-talk on the ALDL line.
that was my conclusion as well, but it's difficult to tell what exactly will get the line clear without begging/borrowing a tech1, otherwise some educated guessing followed by brute force. some of the documentation is close but not quite there.
IDcavy93 wrote:I'm really sorry to hear that you went through that. You and your family/friends are in my prayers!
such is life.

the battle was over before we even knew there was one... I'm told that's just how cancer is, something small and potentially easily curable snowballs into an unyielding monster really, really quickly. we had about 3 months to prepare for the inevitable, that still is gone in a blink.

chevy93
Posts: 2
Joined: Fri Feb 20, 2015 4:08 pm

Post by chevy93 » Fri Feb 20, 2015 4:50 pm

fASTCAV29 wrote:I need a XDF and an ADS for $A1 for a 7730 ecm. I had it but my Hard drive crashed and the site where I got it no longer has it. :cry:

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Fri Feb 20, 2015 4:56 pm

those should be present in the TP definition downloads page.

http://tunerpro.net/downloadBinDefs.htm

xlr8n
Posts: 3
Joined: Wed Apr 22, 2015 12:04 pm

$A0

Post by xlr8n » Wed Apr 22, 2015 12:10 pm

I've not been able to locate an XDF for $A0 (16144288) on the Downloads page. Do you have a copy available to share?

Thanks,

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Wed Apr 22, 2015 2:29 pm


xlr8n
Posts: 3
Joined: Wed Apr 22, 2015 12:04 pm

Post by xlr8n » Thu Apr 23, 2015 4:42 am

Thanks!

Matrix
Posts: 24
Joined: Sun Apr 25, 2010 10:58 am

Post by Matrix » Sat Apr 25, 2015 8:04 pm

Wow, that page for the $A0 has a link to my first attempt at changing a chip program. I figured out how to add the lean highway code from the $42 binary to the $A0 binary.

I posted it a long time ago, but never thought anyone ever looked at it.

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Sat Apr 25, 2015 8:17 pm

something, something, internet is written in ink....

akveps
Posts: 9
Joined: Thu Apr 02, 2015 1:07 pm

ADX for a Volvo Penta GXI-F

Post by akveps » Wed Apr 29, 2015 7:00 pm

Hi Rob,
I saw your post here and thought I would throw this out to you and see if you could offer any suggestions or help.

Do you know where I would find a defintiion file for a GM MEFI-4B?
Its GM Part number is 12584052
Its used in a 2004 GXi-F 5.7L

Not sure what other information I would need to provide, but let me know and I will dig it up.

Im fairly new at this so if you could suggest some good reading sites I will bone up on it.

Thanks in advance,

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Thu Apr 30, 2015 6:47 am

i have an ADX for a MEF3 unit, but I have no idea how similar they are.

akveps
Posts: 9
Joined: Thu Apr 02, 2015 1:07 pm

Post by akveps » Fri May 01, 2015 2:37 pm

Thanks Robert.
I'm not sure how different they are either. I think they are pretty close.

I ordered the MEFIBurn package from ODB Diagnostics so that I can start playing with it, but I'm trying to get a handle on a good definition of the MEFI registers and what each does.

Still very much a newbie.

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Fri May 01, 2015 3:44 pm

well, if they've sent along anything related to the datastream, it could be compared against the MEFI3 ADX I have to see if anything changed there.

xlr8n
Posts: 3
Joined: Wed Apr 22, 2015 12:04 pm

Post by xlr8n » Mon May 04, 2015 10:33 am

Thanks for the link to files.

As a newbie to this whole thing I was happy to capture data using the AULL bin file from the provided link. However, my ECM cover and EPROM label read AULS (see links below for reference). Since the AULS bin is not available how accurate will my data readings be using the other bin files such as AULL, AULK or even AULP since these are the closest to a match? Will either of these files suffice for AULS? If not, what inaccuracies might I expect to encounter?

https://cloud.schichtel.net/public.php? ... c4613c97ed

https://cloud.schichtel.net/public.php? ... 9fe31ea9f9

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Mon May 04, 2015 11:06 am

a BIN isn't necessary to capture accurate data, only that you have the correct ADS/ADX for the BIN you are running.

if you have a PROM burner, you could copy off the AULS BIN that is on your current PROM. that could be your basis for a custom tune, otherwise you would need to decide which of the available BINs is the closest to your application and start with that.

akveps
Posts: 9
Joined: Thu Apr 02, 2015 1:07 pm

MEFI 4B ADX file

Post by akveps » Mon May 04, 2015 7:29 pm

robertisaar wrote:well, if they've sent along anything related to the datastream, it could be compared against the MEFI3 ADX I have to see if anything changed there.
Is an ADX file readable with any software other than TunerPro?
From the output from Scanner Pro I have some information from the MEFI4B such as Hardware version, software revision, software release and calcheck. Do these values help at all in determining what the ADX should look like or what its close to?
Volvo Penta Gxi-F 5.7 with a Mefi4b
GMC 12584052

school costs money...

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Tue May 05, 2015 11:59 am

Tunerpro/Scannerpro are the only software packages that should recognize an ADX.

from what I'm reading up on the MEFIBurn package, it should have the correct ADX with it?

brandonb
Posts: 1
Joined: Thu Jun 04, 2015 12:38 am

Post by brandonb » Thu Jun 04, 2015 1:14 am

could i get a .adx for the $99 6299 ecu in a 1992 C1500 5.7/700R4? i found the .ads, but i need it in .adx

unipro
Posts: 4
Joined: Sun Jul 19, 2015 3:19 am

Newbie would appreciate some help creating ADX for MEFI4b

Post by unipro » Sun Jul 19, 2015 3:49 am

robertisaar wrote:i have an ADX for a MEF3 unit, but I have no idea how similar they are.
Hi there,

Just stumbled over this site, searching on how to read diagnostics from my MEFI4b ECM.
Unfortunately I don't have the protocoll definition for the MEFI4b, so I would like to try the MEFI3 ADX mentioned in this thread.

@robertisaar: could you please send me the MEFI3 ADX?

@All: has anyone got the protocoll definition for MEFI4b?

Many thanks in advance!

Regards
Uli

cbernhardt
Posts: 89
Joined: Fri Apr 18, 2008 5:19 am

Re: Newbie would appreciate some help creating ADX for MEFI4

Post by cbernhardt » Sun Jul 19, 2015 8:43 am

unipro wrote:
robertisaar wrote:i have an ADX for a MEF3 unit, but I have no idea how similar they are.
Hi there,

Just stumbled over this site, searching on how to read diagnostics from my MEFI4b ECM.
Unfortunately I don't have the protocoll definition for the MEFI4b, so I would like to try the MEFI3 ADX mentioned in this thread.

@robertisaar: could you please send me the MEFI3 ADX?

@All: has anyone got the protocoll definition for MEFI4b?

Many thanks in advance!

Regards
Uli
The MEFI4 has a lot more features than the MEFI3 so an MEFI3 definition would probably not help very much. I think the MEFI4a and MEFI4b are the same except the 4b has CAN bus (not certain if this correct). One source for the MEFI scanning and tuning software is OBD Diagnostics (MEFIBurn.com).
If you just want to scan: http://mefiburn.com/mefiscan.asp
I do not think there are any truly "public domain" definition files available.
Is your engine a GM RamJet or a marine application?
Charles

unipro
Posts: 4
Joined: Sun Jul 19, 2015 3:19 am

Post by unipro » Mon Jul 20, 2015 7:35 am

Hi Charles,
Thanks for reply!
My Engine is a Volvo Penta 5.0 Gxi-E, so it's a marine application.
Earlier in this thread I saw robertisaar offering the MEFI3 ADX to somebody else.
As I want to give it a try (and learn more about EFI Diagnostics): I really would appreciate if robertisaar could send the definition file.

Regards
Uli

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Mon Jul 20, 2015 5:21 pm

sorry, that PM slipped my mind after a browser crash, i'll get around to it now.

unipro
Posts: 4
Joined: Sun Jul 19, 2015 3:19 am

Post by unipro » Sat Aug 15, 2015 11:29 pm

robertisaar wrote:sorry, that PM slipped my mind after a browser crash, i'll get around to it now.
Hi robertisaar,

did you send the adx?

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Sun Aug 16, 2015 10:58 pm

I was certain I sent it.... looking back at my PM logs, it appears I did not. I just sent it now, if you have any issues, let me know.

unipro
Posts: 4
Joined: Sun Jul 19, 2015 3:19 am

Post by unipro » Tue Aug 18, 2015 7:00 am

Thanks a lot!
I'll let you know what happens when trying to read the mefi 4 controller with the mefi 3 ADX.
But it'll take some time because I'm on vacation the next weeks.

Janes83
Posts: 9
Joined: Sun Aug 30, 2015 4:08 pm

Post by Janes83 » Mon Sep 14, 2015 12:48 pm

Aimed looking for the correct ADS file to read codes for a 1995 16193495 4.3 (w) , PCs on the passenger side mounted on the overflow tank. 16 pin connection under dash.

0D will not connect.

Thank you.

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Mon Sep 14, 2015 4:16 pm

that might be the early OBD2 PCM?

Janes83
Posts: 9
Joined: Sun Aug 30, 2015 4:08 pm

Post by Janes83 » Mon Sep 14, 2015 4:38 pm

I think so. From what I have read it sounds like it.

How would I go about using my aldl cable / tunerpro combo to read the codes ?

Or do I need a different cable and program to do that ?

Thanks.

Janes83
Posts: 9
Joined: Sun Aug 30, 2015 4:08 pm

Post by Janes83 » Mon Sep 14, 2015 6:13 pm

I have had $0D all,oat connect.

I messed with the baud settings and the connection indicator turned blue and said connected but never saw any change in the engine readings.

Don't know if that means anything .....

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Mon Sep 14, 2015 6:44 pm

if it is the OBD2 unit, you'll need a cable capable of reading the VPW stream it likely pushes out.... I ASSUME it uses a standard OBD2 PID request system the way the full OBD2 implementations do, if so, I would think any basic cable would work. a lot of software options, including the OBD2 plugin for tunerpro.

Janes83
Posts: 9
Joined: Sun Aug 30, 2015 4:08 pm

Post by Janes83 » Mon Sep 14, 2015 7:19 pm

I have the 16 pin -usb cable connector already. I will look up some OBD 2 software and see if that works.

Would I just look for a bin/ ADX file that is associated with a 1996 4.3 ?

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Tue Sep 15, 2015 4:43 am

the issue is that two different sets of hardware are necessary here... the OBD1 stuff just requires a UART to USB bridge, while the OBD2 stuff uses a VPW protocol, with its own hardware requirements. the ELM327 is a common chip for that usage.

Janes83
Posts: 9
Joined: Sun Aug 30, 2015 4:08 pm

Post by Janes83 » Wed Sep 16, 2015 8:19 pm

I took my 16 pin aldl cable plug apart and noticed that there is nothing connected to the #2 pin or the #13 pin or the #16 pin .

Is this correct ?

Because my 16pin plug in the truck has connections in the #2, #13 and #16 pins.

Pins 4&5 have have wires/something attached to them on the usb cable and in the truck plug. So I think those should be good.

But why are those pins left empty on the aldl usb plug ??
[/img]

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Thu Sep 17, 2015 3:04 pm

for your application:

2 is one of the serial data wires, looks like class 2 VPW. pin 9 is also a serial data wire, the normal UART setup as used in most 86+ OBD1 cars.

13 is a circuit that runs to the transfer case.

16 is a 12V feed.


for an OBD1 application(that just has an OBD2 connector, as some 94-95 applications did), not a problem. for an OBD2 application, unless the PCM communicates over the UART link(fairly rare, usually only for aux stuff), it's not going to cut it.

Janes83
Posts: 9
Joined: Sun Aug 30, 2015 4:08 pm

Post by Janes83 » Thu Sep 17, 2015 4:03 pm

So to clarify.

Dash plug has obd2 pin out but is actually obd1 connection.

Usb plug has obd1 pin out.

Vcm under hood is obd1 but inside obd2 housing.

If I re wire usb plug to match the pin out of the dash plug will I be able to connect ?

I have nothing to lose at this point. I can't return the usb plug so if it doesn't work I am out $75. Would have been nice if the manufacturer of this plug stated that it won't work with 16193495 VCM-a 1995 4.3 engines.

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Thu Sep 17, 2015 4:28 pm

your truck is actually more OBD2 than 1...

the data link connector carries a VPW(class 2) datastream, might be able to give a UART stream, the VCM is OBD2(or OBD2ish, at least).

starting in 93, certain 4.3 S/T trucks got some variant of it. the more common one is the 16184738, which seems to have been used 93-95, then 95 got a one-year only unit, the 16193495 you have, then 96 got another one-year deal....

the ALDL index lists a couple of VCM streams, but they're all for LB4 engines, not L35. the L35 streams that are listed are apparently for the more common '7427 type PCM that was also used with the 5.0/5.7.

Janes83
Posts: 9
Joined: Sun Aug 30, 2015 4:08 pm

Post by Janes83 » Thu Sep 17, 2015 5:22 pm

I see. Thank you for u for the assistance.

However I am just going to purchase a acutron9145 handheld unit and see how that works out.

On another note .. If anybody wants to buy a aldl 16 pin USB cable I am willing to let it go for a cheaper price than red devil river. :roll:

hwulff
Posts: 1
Joined: Sat Nov 07, 2015 11:33 am

85 Vett ADX file

Post by hwulff » Sat Nov 07, 2015 11:39 am

Looking for an ADX file for a 870 ECM $1f for Tuner-pro RT, L98 TPI 4 + 3 Doug Nash 307 rear

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Sat Nov 07, 2015 1:30 pm

http://tunerpro.net/downloadBinDefs.htm

should be able to just download the 1F ADS and import it into tunerpro V5 and have it functional.

Mayday69
Posts: 4
Joined: Thu Nov 12, 2015 12:22 am

808 VN commodre .bin .xdf .adx Data tracing

Post by Mayday69 » Thu Nov 12, 2015 12:58 am

Hi, I am new to all this. I have TunerPro RT V5 and using a Moates APU1 Autoprom. I am having heaps of trouble connecting to the ecu and reading data. I found a BIN XDF and ADS file online but no idea if they are the right ones or not. I tried to enable data tracing but cant get it to work. Can anyone point me in the right direction as to the right files to get, and how to get it all working properly? Vehicle is a VN Commodore manual with an 808 ECU Thanks

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Thu Nov 12, 2015 11:40 am

one of the delcohacking.net (now pcmhacking.net) crew could answer that in a second, I'm not too familiar with the Aussie applications though.

Mayday69
Posts: 4
Joined: Thu Nov 12, 2015 12:22 am

Post by Mayday69 » Thu Nov 12, 2015 5:21 pm

I have tried everything to get registered on that page but for some reason I never receive an activation email. Is there another way to get in contact with them without being registered on the forum?

robertisaar
Author of Defs
Posts: 962
Joined: Sat Feb 21, 2009 3:18 pm
Location: Camden, MI

Post by robertisaar » Thu Nov 12, 2015 6:49 pm

most of the moderation team from pcmhacking is actually on here as well...

The1 looks to have posted here most recently, so I'd point you towards his direction.

http://tunerpro.net/forum/profile.php?m ... ile&u=2409

Post Reply