FAQFAQ SearchSearch MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

 
Crashing when entering or editing custom

 
Post new topic   Reply to topic    TunerPro User Forum Forum Index -> Report A Bug
 
jcsbanks



Joined: 15 Feb 2017
Posts: 8

PostPosted: Wed Feb 15, 2017 11:52 am    Post subject: Crashing when entering or editing custom Reply with quote

Windows 10 64 bit Pro. Two different PCs.

Fresh install of Tuner Pro 5.00.8944.00

Open for the first time. Whether xdf and bin loaded or not, go to Tools...Custom Tools... Edit Custom tools... click on an existing tool and immediately there is a TunerPro has stopped working and it closes. Same if you add a new tool, but whilst it crashes the selection is remembered and the tool can be used, although shortcut keys usually don't work.
Back to top
View user's profile Send private message
 

 
Mangus
TunerPro Author


Joined: 19 Mar 2003
Posts: 1786

PostPosted: Wed Feb 15, 2017 2:35 pm    Post subject: Reply with quote

Strange that I can't reproduce this on any of my machines.

In what path do you have TunerPro installed?

Can anyone else corroborate this issue?
_________________
***************************************
TunerPro Author
1989 Trans Am
Back to top
View user's profile Send private message
 

 
jcsbanks



Joined: 15 Feb 2017
Posts: 8

PostPosted: Thu Feb 16, 2017 11:19 pm    Post subject: Reply with quote

This was in the default location which I think was Program Files x86. On one machine also tried C root. Will try some other machines today but the workaround to alter the custom tool is to uninstall and delete TunerPro material in Documents and then reinstall. Is there any more info I can collect?
Back to top
View user's profile Send private message
 

 
jcsbanks



Joined: 15 Feb 2017
Posts: 8

PostPosted: Fri Feb 17, 2017 12:30 am    Post subject: Reply with quote

Terrible quick video.

https://youtu.be/XowXmcnfCXo

Crashes on four Windows 10 machines. Two have Kaspersky, two just Windows 10 security. Nothing fancy with any of the machines, some are very light and recent installs. All UK keyboards. Some SSD some not.

Also tried run as administrator.
Back to top
View user's profile Send private message
 

 
jcsbanks



Joined: 15 Feb 2017
Posts: 8

PostPosted: Fri Feb 17, 2017 7:59 am    Post subject: Reply with quote

New install Windows 10. First thing install TunerPro and crashes in same way.
Back to top
View user's profile Send private message
 

 
Mangus
TunerPro Author


Joined: 19 Mar 2003
Posts: 1786

PostPosted: Fri Feb 17, 2017 8:38 am    Post subject: Reply with quote

What language/locale do you have windows set to?

I'm also running Win10 x64 pro on most of my machines and can't get it to happen. I'll ask around if others can repro.
_________________
***************************************
TunerPro Author
1989 Trans Am
Back to top
View user's profile Send private message
 

 
jcsbanks



Joined: 15 Feb 2017
Posts: 8

PostPosted: Fri Feb 17, 2017 1:09 pm    Post subject: Reply with quote

GB/UK English. Everything as default as can be in Windows installation otherwise.
Back to top
View user's profile Send private message
 

 
pahlok



Joined: 12 Jun 2010
Posts: 11

PostPosted: Wed Jul 05, 2017 11:57 am    Post subject: Reply with quote

jcsbanks wrote:
GB/UK English. Everything as default as can be in Windows installation otherwise.


Did you manage to fix this? I got the same issue
Back to top
View user's profile Send private message
 

 
jcsbanks



Joined: 15 Feb 2017
Posts: 8

PostPosted: Wed Jul 05, 2017 11:59 am    Post subject: Reply with quote

No, not tried changing language. What language are you using?

I have ended up writing a plugin, not because of this but as a better solution.
Back to top
View user's profile Send private message
 

 
pahlok



Joined: 12 Jun 2010
Posts: 11

PostPosted: Wed Jul 05, 2017 12:15 pm    Post subject: Reply with quote

jcsbanks wrote:
No, not tried changing language. What language are you using?

I have ended up writing a plugin, not because of this but as a better solution.


I'm using GB/UK English
Back to top
View user's profile Send private message
 

 
pahlok



Joined: 12 Jun 2010
Posts: 11

PostPosted: Wed Jul 05, 2017 12:24 pm    Post subject: Reply with quote

pahlok wrote:
jcsbanks wrote:
No, not tried changing language. What language are you using?

I have ended up writing a plugin, not because of this but as a better solution.


I'm using GB/UK English


Tried US English but same issue, as soon as I try to open an XDF I get the message "stopped working"
Back to top
View user's profile Send private message
 

 
turboxb12r



Joined: 10 Aug 2017
Posts: 2

PostPosted: Thu Aug 10, 2017 11:44 am    Post subject: Reply with quote

Did anyone ever solve this im having the same issue. tunerpro stops working as soon as i try and load xdf
Back to top
View user's profile Send private message
 

 
Mangus
TunerPro Author


Joined: 19 Mar 2003
Posts: 1786

PostPosted: Thu Aug 10, 2017 11:48 am    Post subject: Reply with quote

The issue described here has nothing to do with loading XDFs.

If you see a crash loading an XDF, best to email me the files I need and instructions to reproduce the issue.

Regarding the original issue (crashing when entering the custom tools configuration), I haven't been able to reproduce this, but it seems to have to do with language settings. I'll try again and fix what I find.
_________________
***************************************
TunerPro Author
1989 Trans Am
Back to top
View user's profile Send private message
 

 
turboxb12r



Joined: 10 Aug 2017
Posts: 2

PostPosted: Thu Aug 10, 2017 1:37 pm    Post subject: Reply with quote

i switched to version 4.14 and everything works just fine maybe ill try and reinstall version 5 and see if it works then. also it would crash trying to do a few different things but this is the first time ever using the program so im not totally sure what else would crash it
Back to top
View user's profile Send private message
 

Display posts from previous:   
View previous topic :: View next topic  
Post new topic   Reply to topic    TunerPro User Forum Forum Index -> Report A Bug All times are GMT - 9 Hours
 
Page 1 of 1
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 


Powered by phpBB © 2001, 2002 phpBB Group
RedSquare theme 1.0.3 © DoubleJ(Jan Jaap)