P4 8192 chatter-

For those of you brave enough to try the beta releases, please ask your questions and post your issues here! Remember, the more info the better!

Moderators: robertisaar, dex

Locked
GMjohn
Posts: 3
Joined: Sun Oct 28, 2007 4:11 pm

P4 8192 chatter-

Post by GMjohn » Sun Oct 28, 2007 4:36 pm

Couple of questions.


I'm working with the latest beta release 05.0574.00

Stream - A097.DS

I am able to connect with no errors, streams about 8-10hz
Good so far. I am unable to sync my stream. My gauges are all over the place. So I sniffed the stream to get an idea of what was happening.
Seems the stream is broadcast whether or not the mode request is sent.
The mode of the stream is determined by the diagnostic enable circuit.
(pin b of aldl) It seems to have hardware mode enable like the 160 baud stuff and the speed of the 8192 stuff.

If I could sync the stream to the 3 byte header 0xF0 0x95 0x01 I should be able to parse the stream.

I was looking into a new command but was unable to come up with anything from the available commands.

Any suggestions?? I was thinking of an 8192 packet command like the 160 baud packet, then again I may be way off here.

Any comments most welcome-

John

GMjohn
Posts: 3
Joined: Sun Oct 28, 2007 4:11 pm

Post by GMjohn » Mon Oct 29, 2007 4:06 pm

Anyone happen to have an 8192 Uni-Directional stream working I can look at?

I am going to try an few things tonight and see what happens.

Thanks,

John

GMjohn
Posts: 3
Joined: Sun Oct 28, 2007 4:11 pm

Post by GMjohn » Mon Oct 29, 2007 8:20 pm

OK, I can maintain stream sync at ~9.5 hz - 10.2+hz

I get data corruption on any thing less than 9.5 hz. I get a momentary drop to around 8hz, data gets scrambled, then back up to 10hz and all is good. Just can't seem to get the timing stable(threading issue??)

John

Locked