FAQFAQ SearchSearch MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

 
Immediate crash when loading XDF

 
Post new topic   Reply to topic    TunerPro User Forum Forum Index -> Report A Bug
 
x99percent



Joined: 19 Sep 2017
Posts: 7

PostPosted: Tue Sep 19, 2017 8:04 am    Post subject: Immediate crash when loading XDF Reply with quote

- Windows 10 Pro, version 1703, build 15063.608 (newer PC, not much loaded on it)
- TunerPro, build 5.00.9107.00

TunerPro crashes when I load this XDF, but the same XDF works on a Windows 7 computer. Not sure where I should be looking to fix the problem.

https://raw.githubusercontent.com/dmacpro91/BMW-XDFs/master/98G0B.xdf
Back to top
View user's profile Send private message
 

 
Mangus
TunerPro Author


Joined: 19 Mar 2003
Posts: 1789

PostPosted: Mon Sep 25, 2017 8:03 am    Post subject: Reply with quote

Are you using the latest build? I can load it without issue. What language/locale is your PC set to?
_________________
***************************************
TunerPro Author
1989 Trans Am
Back to top
View user's profile Send private message
 

 
x99percent



Joined: 19 Sep 2017
Posts: 7

PostPosted: Mon Sep 25, 2017 8:21 am    Post subject: Reply with quote

All version/build info is in the original post.

English/USA
Back to top
View user's profile Send private message
 

 
Mangus
TunerPro Author


Joined: 19 Mar 2003
Posts: 1789

PostPosted: Mon Sep 25, 2017 9:22 am    Post subject: Reply with quote

Can you please email me a bin? Does it crash if you don't have a bin loaded?

Aside from that, you're using exactly the same setup I am, and I cannot repro.
_________________
***************************************
TunerPro Author
1989 Trans Am
Back to top
View user's profile Send private message
 

 
x99percent



Joined: 19 Sep 2017
Posts: 7

PostPosted: Mon Sep 25, 2017 10:55 am    Post subject: Reply with quote

No .bin file is necessary to make it crash.

I've tried uninstalling and reinstalling TunerPro. It also crashes with this XDF:
https://raw.githubusercontent.com/dmacpro91/BMW-XDFs/master/I8A0S%20(Standard%20Units).xdf

(copy/paste the link... BBCode doesn't like the parentheses in the link)
Back to top
View user's profile Send private message
 

 
x99percent



Joined: 19 Sep 2017
Posts: 7

PostPosted: Mon Sep 25, 2017 11:10 am    Post subject: Reply with quote

Is there any way to generate a log file of the crash?
Back to top
View user's profile Send private message
 

 
Mangus
TunerPro Author


Joined: 19 Mar 2003
Posts: 1789

PostPosted: Mon Sep 25, 2017 11:14 am    Post subject: Reply with quote

x99percent wrote:
Is there any way to generate a log file of the crash?


Not unless you have Visual Studio installed, and can attach and generate a crash dump.

Are your settings the same between the two machines (win7/win10)?

I can load both XDFs, here.

What happens if you load it on the Win7 machine, save it out in TunerPro, then open the result in Win10? It looks like these definitions may have been generated by a tool(?).
_________________
***************************************
TunerPro Author
1989 Trans Am
Back to top
View user's profile Send private message
 

 
x99percent



Joined: 19 Sep 2017
Posts: 7

PostPosted: Mon Sep 25, 2017 11:37 am    Post subject: Reply with quote

Mangus wrote:
Are your settings the same between the two machines (win7/win10)?


Haven't made any setting changes.

Last attempt:
- uninstall TunerPro
- delete "Documents\TunerPro Files" and "Program Files (x86)\TunerPro" directories
- reinstall TunerPro
- run it, load XDF
- crash

Mangus wrote:
What happens if you load it on the Win7 machine, save it out in TunerPro, then open the result in Win10? It looks like these definitions may have been generated by a tool(?).


I am using identical XDFs between computers (directories are synced).
Tried saving both XDFs as new files from the Win7 TunerPro, and they still crash on Win10.
Back to top
View user's profile Send private message
 

 
x99percent



Joined: 19 Sep 2017
Posts: 7

PostPosted: Mon Sep 25, 2017 11:43 am    Post subject: Reply with quote

TunerPro build 5.00.8853.00 does not crash..!
Back to top
View user's profile Send private message
 

 
Mangus
TunerPro Author


Joined: 19 Mar 2003
Posts: 1789

PostPosted: Mon Sep 25, 2017 12:00 pm    Post subject: Reply with quote

I've made no changes to XDFs in between. The major change was moving to a new compiler, and ultimately a new C runtime.

Maybe try running windows update to make sure your PC has the llatest runtime installed?

I'm grasping at straws; I have no explanation for why it would work on mine and not yours.
_________________
***************************************
TunerPro Author
1989 Trans Am
Back to top
View user's profile Send private message
 

 
x99percent



Joined: 19 Sep 2017
Posts: 7

PostPosted: Tue Sep 26, 2017 9:55 am    Post subject: Reply with quote

Somewhere between Windows updating to build 15063.632 and upgrading TunerPro from 5.00.8853.00 to 5.00.9107.00, it started working... no more crashes!
Back to top
View user's profile Send private message
 

Display posts from previous:   
View previous topic :: View next topic  
Post new topic   Reply to topic    TunerPro User Forum Forum Index -> Report A Bug All times are GMT - 9 Hours
 
Page 1 of 1
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 


Powered by phpBB © 2001, 2002 phpBB Group
RedSquare theme 1.0.3 © DoubleJ(Jan Jaap)